yjun
5 years ago
committed by
GitHub
3 changed files with 44 additions and 0 deletions
@ -0,0 +1,18 @@ |
|||
diff -uNr --color src.mod/src/resultdom.h src/src/resultdom.h
|
|||
--- src.mod/src/resultdom.h 2020-03-26 16:48:48.851000843 +0800
|
|||
+++ src/src/resultdom.h 2020-03-26 16:52:05.101000768 +0800
|
|||
@@ -22,6 +22,7 @@
|
|||
#include <vector> |
|||
#include <list> |
|||
#include <stdlib.h> |
|||
+#include <locale.h>
|
|||
|
|||
|
|||
class Item //элемент дерева данных (например <disk_usage>1129827635.000000</disk_usage>) |
|||
@@ -53,4 +54,4 @@
|
|||
Item* parent; |
|||
}; |
|||
|
|||
-#endif //RESULTDOM_H
|
|||
\ No newline at end of file |
|||
+#endif //RESULTDOM_H
|
@ -0,0 +1,15 @@ |
|||
TERMUX_PKG_HOMEPAGE=https://sourceforge.net/projects/boinctui/ |
|||
TERMUX_PKG_DESCRIPTION="curses based manager for Boinc client" |
|||
TERMUX_PKG_LICENSE="GPL-3.0" |
|||
TERMUX_PKG_VERSION=2.5.0 |
|||
TERMUX_PKG_SRCURL="https://sourceforge.net/projects/boinctui/files/boinctui_${TERMUX_PKG_VERSION}.tar.gz" |
|||
TERMUX_PKG_SHA256="173dd1231b29eaf5357fa5de612dbce231537c40e631d598a2f49a4f32bafd9b" |
|||
TERMUX_PKG_DEPENDS="glib, libandroid-support, libexpat, ncurses, openssl" |
|||
TERMUX_PKG_BUILD_IN_SRC=true |
|||
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="--without-gnutls" |
|||
|
|||
termux_step_pre_configure() { |
|||
CPPFLAGS+=" -DANDROID" |
|||
LDFLAGS+=" -llog" |
|||
autoconf |
|||
} |
@ -0,0 +1,11 @@ |
|||
diff -uNr boinctui-2.5.0/configure.in boinctui-2.5.0.mod/configure.in
|
|||
--- boinctui-2.5.0/configure.in 2016-09-10 20:01:45.000000000 +0300
|
|||
+++ boinctui-2.5.0.mod/configure.in 2020-03-26 15:21:40.598627902 +0200
|
|||
@@ -39,7 +39,6 @@
|
|||
) |
|||
|
|||
AC_CHECK_LIB(expat, main, , [AC_MSG_ERROR([Couldn't find expat library])] ) |
|||
-AC_CHECK_LIB(pthread, main, , [AC_MSG_ERROR([Couldn't find pthread library])] )
|
|||
|
|||
AC_ARG_WITH( |
|||
[gnutls], |
Loading…
Reference in new issue