Browse Source
When the debian developers come ringing for a tagged release, suddenly everything goes really fast. In the build environment `ncurses5-config --libs` also returns -ltinfo, which is unavailable to the linker. That's why the patch was needed. Is this something that could be fixed in the build environment or is this simply a badly written makefile, unsuitable for cross compiling?android-5
Oliver Schmidhauser
8 years ago
committed by
Fredrik Fornwall
2 changed files with 19 additions and 8 deletions
@ -0,0 +1,14 @@ |
|||
diff --git a/Makefile b/Makefile
|
|||
index 5028ee4..6294b23 100644
|
|||
--- a/Makefile
|
|||
+++ b/Makefile
|
|||
@@ -11,7 +11,8 @@ MANPATH = ${DESTDIR}${PREFIX}/share/man/man1
|
|||
|
|||
ifeq ($(shell sh -c 'which ncurses5-config>/dev/null 2>/dev/null && echo y'), y) |
|||
CFLAGS += -Wall -g $$(ncurses5-config --cflags) |
|||
- LDFLAGS += $$(ncurses5-config --libs)
|
|||
+ # Overwrite instead of appending LDFLAGS, because `ncurses-config --libs` also returns -ltinfo, which it can't find
|
|||
+ LDFLAGS ?= $$(ncurses5-config --libs)
|
|||
else ifeq ($(shell sh -c 'which ncursesw5-config>/dev/null 2>/dev/null && echo y'), y) |
|||
CFLAGS += -Wall -g $$(ncursesw5-config --cflags) |
|||
LDFLAGS += $$(ncursesw5-config --libs) |
Loading…
Reference in new issue