Fredrik Fornwall
6 years ago
3 changed files with 15 additions and 20 deletions
@ -0,0 +1,12 @@ |
|||||
|
diff -u -r ../giflib-5.1.9/Makefile ./Makefile
|
||||
|
--- ../giflib-5.1.9/Makefile 2019-03-28 18:57:23.000000000 +0000
|
||||
|
+++ ./Makefile 2019-03-29 22:55:30.125971028 +0000
|
||||
|
@@ -14,7 +14,7 @@
|
||||
|
TAR = tar |
||||
|
INSTALL = install |
||||
|
|
||||
|
-PREFIX = /usr/local
|
||||
|
+PREFIX ?= /usr/local
|
||||
|
BINDIR = $(PREFIX)/bin |
||||
|
INCDIR = $(PREFIX)/include |
||||
|
LIBDIR = $(PREFIX)/lib |
@ -1,17 +0,0 @@ |
|||||
--- src/lib/egif_lib.c.orig 2017-12-09 15:46:41.761228962 +0000
|
|
||||
+++ src/lib/egif_lib.c 2017-12-09 15:47:16.631668749 +0000
|
|
||||
@@ -25,6 +25,14 @@
|
|
||||
#include "gif_lib.h" |
|
||||
#include "gif_lib_private.h" |
|
||||
|
|
||||
+#ifndef S_IREAD
|
|
||||
+#define S_IREAD 00400
|
|
||||
+#endif
|
|
||||
+
|
|
||||
+#ifndef S_IWRITE
|
|
||||
+#define S_IWRITE 00200
|
|
||||
+#endif
|
|
||||
+
|
|
||||
/* Masks given codes to BitsPerPixel, to make sure all codes are in range: */ |
|
||||
/*@+charint@*/ |
|
||||
static const GifPixelType CodeMask[] = { |
|
Loading…
Reference in new issue