Browse Source
ncmpcpp segfaults on android 9 because it picks up iconv in libc.so if we don't link against libandroid-support.so properly. This fixes https://github.com/termux/termux-packages/issues/3333.emacs-27
Henrik Grimler
6 years ago
2 changed files with 12 additions and 1 deletions
@ -0,0 +1,11 @@ |
|||||
|
--- ../configure.ac.orig 2019-04-13 16:42:43.319705874 +0000
|
||||
|
+++ ./configure.ac 2019-04-13 16:42:50.146372491 +0000
|
||||
|
@@ -78,7 +78,7 @@
|
||||
|
AC_SUBST(BOOST_LOCALE_LDFLAGS) |
||||
|
AC_SUBST(BOOST_LOCALE_LIBS) |
||||
|
LDFLAGS="$LDFLAGS $BOOST_LOCALE_LDFLAGS" |
||||
|
-LIBS="$LIBS $BOOST_LOCALE_LIBS"
|
||||
|
+LIBS="$LIBS $BOOST_LOCALE_LIBS -landroid-support"
|
||||
|
|
||||
|
BOOST_PROGRAM_OPTIONS |
||||
|
AC_SUBST(BOOST_PROGRAM_OPTIONS_LDFLAGS) |
Loading…
Reference in new issue