|
|
@ -1,6 +1,7 @@ |
|
|
|
--- ../cache/vifm-0.9/configure.ac 2017-06-18 14:31:25.000000000 +0000
|
|
|
|
+++ ./configure.ac 2017-10-03 23:29:41.348507964 +0000
|
|
|
|
@@ -145,18 +145,11 @@
|
|
|
|
diff -u -r ../vifm-0.9.1/configure.ac ./configure.ac
|
|
|
|
--- ../vifm-0.9.1/configure.ac 2018-02-05 10:40:02.000000000 +0000
|
|
|
|
+++ ./configure.ac 2018-02-06 13:53:38.873777524 +0000
|
|
|
|
@@ -154,18 +154,11 @@
|
|
|
|
AC_CHECK_FUNC([getcwd], [], [AC_MSG_ERROR([getcwd() function not found.])]) |
|
|
|
AC_CHECK_FUNC([getenv], [], [AC_MSG_ERROR([getenv() function not found.])]) |
|
|
|
AC_CHECK_FUNC([geteuid], [], [AC_MSG_ERROR([geteuid() function not found.])]) |
|
|
@ -19,7 +20,7 @@ |
|
|
|
AC_CHECK_FUNC([getpwuid_r], [], [AC_MSG_ERROR([getpwuid_r() function not found.])]) |
|
|
|
AC_CHECK_FUNC([ioctl], [], [AC_MSG_ERROR([ioctl() function not found.])]) |
|
|
|
AC_CHECK_FUNC([iswalnum], [], [AC_MSG_ERROR([iswalnum() function not found.])]) |
|
|
|
@@ -192,13 +185,11 @@
|
|
|
|
@@ -201,13 +194,11 @@
|
|
|
|
AC_CHECK_FUNC([rmdir], [], [AC_MSG_ERROR([rmdir() function not found.])]) |
|
|
|
AC_CHECK_FUNC([select], [], [AC_MSG_ERROR([select() function not found.])]) |
|
|
|
AC_CHECK_FUNC([setenv], [], [AC_MSG_ERROR([setenv() function not found.])]) |
|
|
@ -33,15 +34,22 @@ |
|
|
|
AC_CHECK_FUNC([setsid], [], [AC_MSG_ERROR([setsid() function not found.])]) |
|
|
|
AC_CHECK_FUNC([setvbuf], [], [AC_MSG_ERROR([setvbuf() function not found.])]) |
|
|
|
AC_CHECK_FUNC([sigaction], [], [AC_MSG_ERROR([sigaction() function not found.])]) |
|
|
|
@@ -371,11 +362,6 @@
|
|
|
|
@@ -384,18 +375,6 @@
|
|
|
|
dnl from libc) |
|
|
|
AC_CHECK_LIB(m, pow, [LIBS="$LIBS -lm"]) |
|
|
|
|
|
|
|
dnl Use pthread library |
|
|
|
-AC_CHECK_LIB(pthread, pthread_create,
|
|
|
|
-dnl Use pthread library
|
|
|
|
-AX_CHECK_COMPILE_FLAG([-pthread], [
|
|
|
|
- TESTS_CFLAGS="$CFLAGS -pthread"
|
|
|
|
- CFLAGS="$CFLAGS -pthread"
|
|
|
|
- ], [
|
|
|
|
- AC_CHECK_LIB(pthread, pthread_create,
|
|
|
|
- [LIBS="$LIBS -lpthread"
|
|
|
|
- AC_CHECK_HEADER([pthread.h], [], [AC_MSG_ERROR([pthread.h header not found.])])
|
|
|
|
- ],
|
|
|
|
- [AC_MSG_ERROR([libpthread not found])])
|
|
|
|
|
|
|
|
- ])
|
|
|
|
-
|
|
|
|
dnl Check for all required elements in pthread.h. |
|
|
|
AC_CHECK_FUNC([pthread_create], [], [AC_MSG_ERROR([pthread_create() function not found.])]) |
|
|
|
AC_CHECK_FUNC([pthread_getspecific], [], [AC_MSG_ERROR([pthread_getspecific() function not found.])]) |
|
|
|