Henrik Grimler
6 years ago
21 changed files with 166 additions and 28 deletions
@ -1,9 +1,8 @@ |
|||
TERMUX_PKG_HOMEPAGE=http://bs1770gain.sourceforge.net/ |
|||
TERMUX_PKG_DESCRIPTION="Tool to normalize the loudness of different audio files to the same level" |
|||
TERMUX_PKG_LICENSE="GPL-2.0" |
|||
TERMUX_PKG_VERSION=0.5.1 |
|||
TERMUX_PKG_REVISION=1 |
|||
TERMUX_PKG_VERSION=0.5.2 |
|||
TERMUX_PKG_SHA256=73e5738786b57afb89582333ed18206fd2c6d5245717d3b24ace7f7670f9dedc |
|||
TERMUX_PKG_SRCURL=https://downloads.sourceforge.net/project/bs1770gain/bs1770gain/${TERMUX_PKG_VERSION}/bs1770gain-${TERMUX_PKG_VERSION}.tar.gz |
|||
TERMUX_PKG_SHA256=06749f866417e6bcdb9fb24883cb08ae54248333a532380c7ddc56f7a45a8e64 |
|||
TERMUX_PKG_DEPENDS="ffmpeg, sox" |
|||
|
|||
|
@ -0,0 +1,12 @@ |
|||
diff -u -r ../hub-2.8.3/script/build ./script/build
|
|||
--- ../hub-2.8.3/script/build 2019-01-26 17:47:05.000000000 +0000
|
|||
+++ ./script/build 2019-01-27 08:10:53.521236847 +0000
|
|||
@@ -14,7 +14,7 @@
|
|||
build_hub() { |
|||
mkdir -p "$(dirname "$1")" |
|||
go build \ |
|||
- -ldflags "-X github.com/github/hub/version.Version=`./script/version` $LDFLAGS" \
|
|||
+ -ldflags "-X github.com/github/hub/version.Version=`./script/version`" \
|
|||
-gcflags "$GCFLAGS" \ |
|||
-asmflags "$ASMFLAGS" \ |
|||
-o "$1" |
@ -0,0 +1,13 @@ |
|||
--- radare2-3.2.1_2/shlr/Makefile
|
|||
+++ radare2-3.2.1/shlr/Makefile
|
|||
@@ -25,8 +25,8 @@
|
|||
CS_URL=$(GIT_PREFIX)github.com/aquynh/capstone.git |
|||
CS_UPD=20181224 |
|||
# NOTE: when you update CS_TIP or CS_BRA, also update them in shlr/meson.build |
|||
-CS_BRA=v4.1
|
|||
-CS_TIP=0ff8220adef16a942697afd245afc5ab0f70cbf8
|
|||
+CS_BRA=master
|
|||
+CS_TIP=58a80a93f995c23a8681dcc38dccfc6bab9cd7a4
|
|||
# REVERT THIS COMMIT BECAUSE ITS WRONG |
|||
CS_REV= |
|||
CS_PATCHES=1 |
@ -0,0 +1,43 @@ |
|||
Submitted upstream at https://github.com/michalbednarski/TermuxAm/pull/4 |
|||
|
|||
diff --git a/app/build.gradle b/app/build.gradle
|
|||
index 7888fcd..07c189e 100644
|
|||
--- a/app/build.gradle
|
|||
+++ b/app/build.gradle
|
|||
@@ -1,11 +1,11 @@
|
|||
apply plugin: 'com.android.application' |
|||
|
|||
android { |
|||
- compileSdkVersion 26
|
|||
+ compileSdkVersion 28
|
|||
defaultConfig { |
|||
applicationId "com.example.termuxam" |
|||
minSdkVersion 21 |
|||
- targetSdkVersion 26
|
|||
+ targetSdkVersion 28
|
|||
versionCode 1 |
|||
versionName "0.1" |
|||
testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner" |
|||
diff --git a/build.gradle b/build.gradle
|
|||
index e6b32bc..6c2bb63 100644
|
|||
--- a/build.gradle
|
|||
+++ b/build.gradle
|
|||
@@ -7,7 +7,7 @@ buildscript {
|
|||
jcenter() |
|||
} |
|||
dependencies { |
|||
- classpath 'com.android.tools.build:gradle:3.0.1'
|
|||
+ classpath 'com.android.tools.build:gradle:3.3.0'
|
|||
|
|||
|
|||
// NOTE: Do not place your application dependencies here; they belong |
|||
diff --git a/gradle/wrapper/gradle-wrapper.properties b/gradle/wrapper/gradle-wrapper.properties
|
|||
index a23653e..4f86dee 100644
|
|||
--- a/gradle/wrapper/gradle-wrapper.properties
|
|||
+++ b/gradle/wrapper/gradle-wrapper.properties
|
|||
@@ -3,4 +3,4 @@ distributionBase=GRADLE_USER_HOME
|
|||
distributionPath=wrapper/dists |
|||
zipStoreBase=GRADLE_USER_HOME |
|||
zipStorePath=wrapper/dists |
|||
-distributionUrl=https\://services.gradle.org/distributions/gradle-4.1-all.zip
|
|||
+distributionUrl=https\://services.gradle.org/distributions/gradle-5.1.1-all.zip
|
@ -0,0 +1,38 @@ |
|||
diff -u -r ../unzip60/unzip.c ./unzip.c
|
|||
--- ../unzip60/unzip.c 2009-04-16 18:26:52.000000000 +0000
|
|||
+++ ./unzip.c 2019-01-27 06:36:11.933232400 +0000
|
|||
@@ -762,34 +762,7 @@
|
|||
/* see if can use UTF-8 Unicode locale */ |
|||
# ifdef UTF8_MAYBE_NATIVE |
|||
{ |
|||
- char *codeset;
|
|||
-# if !(defined(NO_NL_LANGINFO) || defined(NO_LANGINFO_H))
|
|||
- /* get the codeset (character set encoding) currently used */
|
|||
-# include <langinfo.h>
|
|||
-
|
|||
- codeset = nl_langinfo(CODESET);
|
|||
-# else /* NO_NL_LANGINFO || NO_LANGINFO_H */
|
|||
- /* query the current locale setting for character classification */
|
|||
- codeset = setlocale(LC_CTYPE, NULL);
|
|||
- if (codeset != NULL) {
|
|||
- /* extract the codeset portion of the locale name */
|
|||
- codeset = strchr(codeset, '.');
|
|||
- if (codeset != NULL) ++codeset;
|
|||
- }
|
|||
-# endif /* ?(NO_NL_LANGINFO || NO_LANGINFO_H) */
|
|||
- /* is the current codeset UTF-8 ? */
|
|||
- if ((codeset != NULL) && (strcmp(codeset, "UTF-8") == 0)) {
|
|||
- /* successfully found UTF-8 char coding */
|
|||
G.native_is_utf8 = TRUE; |
|||
- } else {
|
|||
- /* Current codeset is not UTF-8 or cannot be determined. */
|
|||
- G.native_is_utf8 = FALSE;
|
|||
- }
|
|||
- /* Note: At least for UnZip, trying to change the process codeset to
|
|||
- * UTF-8 does not work. For the example Linux setup of the
|
|||
- * UnZip maintainer, a successful switch to "en-US.UTF-8"
|
|||
- * resulted in garbage display of all non-basic ASCII characters.
|
|||
- */
|
|||
} |
|||
# endif /* UTF8_MAYBE_NATIVE */ |
|||
|
Loading…
Reference in new issue