Fredrik Fornwall
8 years ago
3 changed files with 25 additions and 182 deletions
@ -1,23 +1,25 @@ |
|||||
diff -u -r ../procps-ng-3.3.11/Makefile.in ./Makefile.in
|
Bionic lacks strverscmp as well. |
||||
--- ../procps-ng-3.3.11/Makefile.in 2015-08-09 03:57:07.937259593 -0400
|
|
||||
+++ ./Makefile.in 2015-12-15 06:46:35.530449934 -0500
|
diff -u -r ../procps-ng-3.3.12/Makefile.in ./Makefile.in
|
||||
@@ -296,9 +296,11 @@
|
--- ../procps-ng-3.3.12/Makefile.in 2016-07-10 01:32:11.170237828 -0400
|
||||
tload_LDADD = $(LDADD) |
+++ ./Makefile.in 2016-08-14 18:07:17.324636393 -0400
|
||||
tload_DEPENDENCIES = ./proc/libprocps.la |
@@ -112,7 +112,7 @@
|
||||
|
@WITH_NCURSES_TRUE@ watch.1 \ |
||||
|
@WITH_NCURSES_TRUE@ top/top.1 |
||||
|
|
||||
|
-@CYGWIN_TRUE@@WITH_NCURSES_TRUE@am__append_10 = lib/strverscmp.c
|
||||
|
+@WITH_NCURSES_TRUE@am__append_10 = lib/strverscmp.c
|
||||
|
@BUILD_SKILL_TRUE@am__append_11 = \ |
||||
|
@BUILD_SKILL_TRUE@ skill \ |
||||
|
@BUILD_SKILL_TRUE@ snice |
||||
|
@@ -308,8 +308,8 @@
|
||||
|
tload_DEPENDENCIES = ./proc/libprocps.la $(am__DEPENDENCIES_2) |
||||
am__top_top_SOURCES_DIST = top/top.h top/top.c top/top_nls.h \ |
am__top_top_SOURCES_DIST = top/top.h top/top.c top/top_nls.h \ |
||||
+ top/strverscmp.c \
|
top/top_nls.c lib/fileutils.c lib/strverscmp.c |
||||
top/top_nls.c lib/fileutils.c |
-@CYGWIN_TRUE@@WITH_NCURSES_TRUE@am__objects_1 = \
|
||||
|
-@CYGWIN_TRUE@@WITH_NCURSES_TRUE@ lib/strverscmp.$(OBJEXT)
|
||||
|
+@WITH_NCURSES_TRUE@am__objects_1 = \
|
||||
|
+@WITH_NCURSES_TRUE@ lib/strverscmp.$(OBJEXT)
|
||||
@WITH_NCURSES_TRUE@am_top_top_OBJECTS = top/top.$(OBJEXT) \ |
@WITH_NCURSES_TRUE@am_top_top_OBJECTS = top/top.$(OBJEXT) \ |
||||
@WITH_NCURSES_TRUE@ top/top_nls.$(OBJEXT) \ |
@WITH_NCURSES_TRUE@ top/top_nls.$(OBJEXT) \ |
||||
+@WITH_NCURSES_TRUE@ top/strverscmp.$(OBJEXT) \
|
@WITH_NCURSES_TRUE@ lib/fileutils.$(OBJEXT) $(am__objects_1) |
||||
@WITH_NCURSES_TRUE@ lib/fileutils.$(OBJEXT) |
|
||||
top_top_OBJECTS = $(am_top_top_OBJECTS) |
|
||||
@WITH_NCURSES_TRUE@top_top_DEPENDENCIES = $(LDADD) \ |
|
||||
@@ -661,6 +663,7 @@
|
|
||||
@WITH_NCURSES_TRUE@top_top_SOURCES = \ |
|
||||
@WITH_NCURSES_TRUE@ top/top.h \ |
|
||||
@WITH_NCURSES_TRUE@ top/top.c \ |
|
||||
+@WITH_NCURSES_TRUE@ top/strverscmp.c \
|
|
||||
@WITH_NCURSES_TRUE@ top/top_nls.h \ |
|
||||
@WITH_NCURSES_TRUE@ top/top_nls.c \ |
|
||||
@WITH_NCURSES_TRUE@ lib/fileutils.c |
|
||||
|
@ -1,160 +0,0 @@ |
|||||
diff -N -u -r ../procps-ng-3.3.9/top/strverscmp.c ./top/strverscmp.c
|
|
||||
--- ../procps-ng-3.3.9/top/strverscmp.c 1970-01-01 01:00:00.000000000 +0100
|
|
||||
+++ ./top/strverscmp.c 2014-07-06 07:26:13.650946884 +0200
|
|
||||
@@ -0,0 +1,156 @@
|
|
||||
+/* Compare strings while treating digits characters numerically.
|
|
||||
+ Copyright (C) 1997, 2002, 2005 Free Software Foundation, Inc.
|
|
||||
+ This file is part of the libiberty library.
|
|
||||
+ Contributed by Jean-François Bignolles <bignolle@ecoledoc.ibp.fr>, 1997.
|
|
||||
+
|
|
||||
+ Libiberty is free software; you can redistribute it and/or
|
|
||||
+ modify it under the terms of the GNU Lesser General Public
|
|
||||
+ License as published by the Free Software Foundation; either
|
|
||||
+ version 2.1 of the License, or (at your option) any later version.
|
|
||||
+
|
|
||||
+ Libiberty is distributed in the hope that it will be useful,
|
|
||||
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
||||
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
||||
+ Lesser General Public License for more details.
|
|
||||
+
|
|
||||
+ You should have received a copy of the GNU Lesser General Public
|
|
||||
+ License along with the GNU C Library; if not, write to the Free
|
|
||||
+ Software Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA
|
|
||||
+ 02110-1301 USA. */
|
|
||||
+
|
|
||||
+#include <ctype.h>
|
|
||||
+
|
|
||||
+/*
|
|
||||
+@deftypefun int strverscmp (const char *@var{s1}, const char *@var{s2})
|
|
||||
+The @code{strverscmp} function compares the string @var{s1} against
|
|
||||
+@var{s2}, considering them as holding indices/version numbers. Return
|
|
||||
+value follows the same conventions as found in the @code{strverscmp}
|
|
||||
+function. In fact, if @var{s1} and @var{s2} contain no digits,
|
|
||||
+@code{strverscmp} behaves like @code{strcmp}.
|
|
||||
+
|
|
||||
+Basically, we compare strings normally (character by character), until
|
|
||||
+we find a digit in each string - then we enter a special comparison
|
|
||||
+mode, where each sequence of digits is taken as a whole. If we reach the
|
|
||||
+end of these two parts without noticing a difference, we return to the
|
|
||||
+standard comparison mode. There are two types of numeric parts:
|
|
||||
+"integral" and "fractional" (those begin with a '0'). The types
|
|
||||
+of the numeric parts affect the way we sort them:
|
|
||||
+
|
|
||||
+@itemize @bullet
|
|
||||
+@item
|
|
||||
+integral/integral: we compare values as you would expect.
|
|
||||
+
|
|
||||
+@item
|
|
||||
+fractional/integral: the fractional part is less than the integral one.
|
|
||||
+Again, no surprise.
|
|
||||
+
|
|
||||
+@item
|
|
||||
+fractional/fractional: the things become a bit more complex.
|
|
||||
+If the common prefix contains only leading zeroes, the longest part is less
|
|
||||
+than the other one; else the comparison behaves normally.
|
|
||||
+@end itemize
|
|
||||
+
|
|
||||
+@smallexample
|
|
||||
+strverscmp ("no digit", "no digit")
|
|
||||
+ @result{} 0 // @r{same behavior as strcmp.}
|
|
||||
+strverscmp ("item#99", "item#100")
|
|
||||
+ @result{} <0 // @r{same prefix, but 99 < 100.}
|
|
||||
+strverscmp ("alpha1", "alpha001")
|
|
||||
+ @result{} >0 // @r{fractional part inferior to integral one.}
|
|
||||
+strverscmp ("part1_f012", "part1_f01")
|
|
||||
+ @result{} >0 // @r{two fractional parts.}
|
|
||||
+strverscmp ("foo.009", "foo.0")
|
|
||||
+ @result{} <0 // @r{idem, but with leading zeroes only.}
|
|
||||
+@end smallexample
|
|
||||
+
|
|
||||
+This function is especially useful when dealing with filename sorting,
|
|
||||
+because filenames frequently hold indices/version numbers.
|
|
||||
+@end deftypefun
|
|
||||
+
|
|
||||
+*/
|
|
||||
+
|
|
||||
+/* states: S_N: normal, S_I: comparing integral part, S_F: comparing
|
|
||||
+ fractional parts, S_Z: idem but with leading Zeroes only */
|
|
||||
+#define S_N 0x0
|
|
||||
+#define S_I 0x4
|
|
||||
+#define S_F 0x8
|
|
||||
+#define S_Z 0xC
|
|
||||
+
|
|
||||
+/* result_type: CMP: return diff; LEN: compare using len_diff/diff */
|
|
||||
+#define CMP 2
|
|
||||
+#define LEN 3
|
|
||||
+
|
|
||||
+
|
|
||||
+/* Compare S1 and S2 as strings holding indices/version numbers,
|
|
||||
+ returning less than, equal to or greater than zero if S1 is less than,
|
|
||||
+ equal to or greater than S2 (for more info, see the Glibc texinfo doc). */
|
|
||||
+
|
|
||||
+int
|
|
||||
+strverscmp (const char *s1, const char *s2)
|
|
||||
+{
|
|
||||
+ const unsigned char *p1 = (const unsigned char *) s1;
|
|
||||
+ const unsigned char *p2 = (const unsigned char *) s2;
|
|
||||
+ unsigned char c1, c2;
|
|
||||
+ int state;
|
|
||||
+ int diff;
|
|
||||
+
|
|
||||
+ /* Symbol(s) 0 [1-9] others (padding)
|
|
||||
+ Transition (10) 0 (01) d (00) x (11) - */
|
|
||||
+ static const unsigned int next_state[] =
|
|
||||
+ {
|
|
||||
+ /* state x d 0 - */
|
|
||||
+ /* S_N */ S_N, S_I, S_Z, S_N,
|
|
||||
+ /* S_I */ S_N, S_I, S_I, S_I,
|
|
||||
+ /* S_F */ S_N, S_F, S_F, S_F,
|
|
||||
+ /* S_Z */ S_N, S_F, S_Z, S_Z
|
|
||||
+ };
|
|
||||
+
|
|
||||
+ static const int result_type[] =
|
|
||||
+ {
|
|
||||
+ /* state x/x x/d x/0 x/- d/x d/d d/0 d/-
|
|
||||
+ 0/x 0/d 0/0 0/- -/x -/d -/0 -/- */
|
|
||||
+
|
|
||||
+ /* S_N */ CMP, CMP, CMP, CMP, CMP, LEN, CMP, CMP,
|
|
||||
+ CMP, CMP, CMP, CMP, CMP, CMP, CMP, CMP,
|
|
||||
+ /* S_I */ CMP, -1, -1, CMP, +1, LEN, LEN, CMP,
|
|
||||
+ +1, LEN, LEN, CMP, CMP, CMP, CMP, CMP,
|
|
||||
+ /* S_F */ CMP, CMP, CMP, CMP, CMP, LEN, CMP, CMP,
|
|
||||
+ CMP, CMP, CMP, CMP, CMP, CMP, CMP, CMP,
|
|
||||
+ /* S_Z */ CMP, +1, +1, CMP, -1, CMP, CMP, CMP,
|
|
||||
+ -1, CMP, CMP, CMP
|
|
||||
+ };
|
|
||||
+
|
|
||||
+ if (p1 == p2)
|
|
||||
+ return 0;
|
|
||||
+
|
|
||||
+ c1 = *p1++;
|
|
||||
+ c2 = *p2++;
|
|
||||
+ /* Hint: '0' is a digit too. */
|
|
||||
+ state = S_N | ((c1 == '0') + (isdigit (c1) != 0));
|
|
||||
+
|
|
||||
+ while ((diff = c1 - c2) == 0 && c1 != '\0')
|
|
||||
+ {
|
|
||||
+ state = next_state[state];
|
|
||||
+ c1 = *p1++;
|
|
||||
+ c2 = *p2++;
|
|
||||
+ state |= (c1 == '0') + (isdigit (c1) != 0);
|
|
||||
+ }
|
|
||||
+
|
|
||||
+ state = result_type[state << 2 | (((c2 == '0') + (isdigit (c2) != 0)))];
|
|
||||
+
|
|
||||
+ switch (state)
|
|
||||
+ {
|
|
||||
+ case CMP:
|
|
||||
+ return diff;
|
|
||||
+
|
|
||||
+ case LEN:
|
|
||||
+ while (isdigit (*p1++))
|
|
||||
+ if (!isdigit (*p2++))
|
|
||||
+ return 1;
|
|
||||
+
|
|
||||
+ return isdigit (*p2) ? -1 : diff;
|
|
||||
+
|
|
||||
+ default:
|
|
||||
+ return state;
|
|
||||
+ }
|
|
||||
+}
|
|
Loading…
Reference in new issue