its-pointless
5 years ago
committed by
Leonid Plyushch
7 changed files with 48 additions and 56 deletions
@ -0,0 +1,7 @@ |
|||
TERMUX_PKG_HOMEPAGE=https://github.com/kkos/oniguruma |
|||
TERMUX_PKG_DESCRIPTION="regular expressions library" |
|||
TERMUX_PKG_VERSION=6.9.4 |
|||
TERMUX_PKG_SRCURL=https://github.com/kkos/oniguruma/releases/download/v6.9.4/onig-6.9.4.tar.gz |
|||
TERMUX_PKG_SHA256=4669d22ff7e0992a7e93e116161cac9c0949cd8960d1c562982026726f0e6d53 |
|||
TERMUX_PKG_LICENSE="BSD" |
|||
|
@ -1,14 +0,0 @@ |
|||
Work around https://github.com/android-ndk/ndk/issues/201. |
|||
|
|||
diff -u -r ../php-7.1.6/Makefile.global ./Makefile.global
|
|||
--- ../php-7.1.6/Makefile.global 2017-06-07 10:09:38.000000000 +0200
|
|||
+++ ./Makefile.global 2017-06-14 23:22:21.258154325 +0200
|
|||
@@ -16,7 +16,7 @@
|
|||
build-binaries: $(PHP_BINARIES) |
|||
|
|||
libphp$(PHP_MAJOR_VERSION).la: $(PHP_GLOBAL_OBJS) $(PHP_SAPI_OBJS) |
|||
- $(LIBTOOL) --mode=link $(CC) $(CFLAGS) $(EXTRA_CFLAGS) -rpath $(phptempdir) $(EXTRA_LDFLAGS) $(LDFLAGS) $(PHP_RPATHS) $(PHP_GLOBAL_OBJS) $(PHP_SAPI_OBJS) $(EXTRA_LIBS) $(ZEND_EXTRA_LIBS) -o $@
|
|||
+ $(LIBTOOL) --mode=link $(CC) $(CFLAGS) $(EXTRA_CFLAGS) -rpath $(phptempdir) $(EXTRA_LDFLAGS) $(LDFLAGS) $(PHP_RPATHS) $(PHP_GLOBAL_OBJS) $(PHP_SAPI_OBJS) $(EXTRA_LIBS) -lapr-1 -laprutil-1 $(ZEND_EXTRA_LIBS) -o $@
|
|||
-@$(LIBTOOL) --silent --mode=install cp $@ $(phptempdir)/$@ >/dev/null 2>&1 |
|||
|
|||
libs/libphp$(PHP_MAJOR_VERSION).bundle: $(PHP_GLOBAL_OBJS) $(PHP_SAPI_OBJS) |
@ -0,0 +1,14 @@ |
|||
--- /home/builder/.termux-build/php/src/Zend/zend_alloc.h.orig 2019-12-29 20:42:25.958615960 +0000
|
|||
+++ ./Zend/zend_alloc.h 2019-12-29 20:46:26.512651734 +0000
|
|||
@@ -27,7 +27,11 @@
|
|||
#include "zend.h" |
|||
|
|||
#ifndef ZEND_MM_ALIGNMENT |
|||
+#ifdef __ANDROID__
|
|||
+# define ZEND_MM_ALIGNMENT 8
|
|||
+#else
|
|||
# define ZEND_MM_ALIGNMENT ((size_t) 8) |
|||
+#endif
|
|||
# define ZEND_MM_ALIGNMENT_LOG2 Z_L(3) |
|||
#elif ZEND_MM_ALIGNMENT < 4 |
|||
# undef ZEND_MM_ALIGNMENT |
Loading…
Reference in new issue