Fredrik Fornwall
6 years ago
5 changed files with 67 additions and 0 deletions
@ -0,0 +1,12 @@ |
|||||
|
diff -u -r ../exa-57e4c08411f59e7db91fa7d8127fbd412667ea32/Cargo.toml ./Cargo.toml
|
||||
|
--- ../exa-57e4c08411f59e7db91fa7d8127fbd412667ea32/Cargo.toml 2018-10-14 15:21:13.000000000 +0000
|
||||
|
+++ ./Cargo.toml 2018-10-18 03:04:56.228613011 +0000
|
||||
|
@@ -41,7 +41,7 @@
|
||||
|
term_grid = "0.1.6" |
||||
|
term_size = "0.3.0" |
||||
|
unicode-width = "0.1.4" |
||||
|
-users = "0.7"
|
||||
|
+users = { git = "https://github.com/fornwall/rust-users", branch = "fix-android-build" }
|
||||
|
zoneinfo_compiled = "0.4.7" |
||||
|
|
||||
|
[build-dependencies] |
@ -0,0 +1,18 @@ |
|||||
|
TERMUX_PKG_HOMEPAGE=https://the.exa.website |
||||
|
TERMUX_PKG_DESCRIPTION="A modern replacement for ls" |
||||
|
TERMUX_PKG_VERSION=0.9~pre1 |
||||
|
TERMUX_PKG_SHA256=3cec8e192dd5b69e650605a1948832d4d52ad25d37deecb49a180df020449f54 |
||||
|
TERMUX_PKG_SRCURL=https://github.com/ogham/exa/archive/57e4c08411f59e7db91fa7d8127fbd412667ea32.zip |
||||
|
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="--no-default-features --features default" |
||||
|
TERMUX_PKG_BUILD_IN_SRC=yes |
||||
|
|
||||
|
termux_step_pre_configure() { |
||||
|
rm $TERMUX_PKG_SRCDIR/Makefile |
||||
|
termux_setup_rust |
||||
|
cargo update |
||||
|
} |
||||
|
|
||||
|
termux_step_post_make_install() { |
||||
|
mkdir -p $TERMUX_PREFIX/share/man/man1 |
||||
|
cp $TERMUX_PKG_SRCDIR/contrib/man/exa.1 $TERMUX_PREFIX/share/man/man1/ |
||||
|
} |
@ -0,0 +1,12 @@ |
|||||
|
diff -u -r ../exa-57e4c08411f59e7db91fa7d8127fbd412667ea32/src/output/render/groups.rs ./src/output/render/groups.rs
|
||||
|
--- ../exa-57e4c08411f59e7db91fa7d8127fbd412667ea32/src/output/render/groups.rs 2018-10-14 15:21:13.000000000 +0000
|
||||
|
+++ ./src/output/render/groups.rs 2018-10-18 03:12:48.223359766 +0000
|
||||
|
@@ -24,7 +24,7 @@
|
||||
|
} |
||||
|
} |
||||
|
|
||||
|
- TextCell::paint(style, group.name().to_owned())
|
||||
|
+ TextCell::paint(style, group.name().to_str().unwrap().to_owned())
|
||||
|
} |
||||
|
} |
||||
|
|
@ -0,0 +1,12 @@ |
|||||
|
diff -u -r ../exa-57e4c08411f59e7db91fa7d8127fbd412667ea32/src/output/render/users.rs ./src/output/render/users.rs
|
||||
|
--- ../exa-57e4c08411f59e7db91fa7d8127fbd412667ea32/src/output/render/users.rs 2018-10-14 15:21:13.000000000 +0000
|
||||
|
+++ ./src/output/render/users.rs 2018-10-18 03:13:18.959014671 +0000
|
||||
|
@@ -9,7 +9,7 @@
|
||||
|
impl f::User { |
||||
|
pub fn render<C: Colours, U: Users>(&self, colours: &C, users: &U) -> TextCell { |
||||
|
let user_name = match users.get_user_by_uid(self.0) { |
||||
|
- Some(user) => user.name().to_owned(),
|
||||
|
+ Some(user) => user.name().to_str().unwrap().to_owned(),
|
||||
|
None => self.0.to_string(), |
||||
|
}; |
||||
|
|
@ -0,0 +1,13 @@ |
|||||
|
diff -u -r ../exa-57e4c08411f59e7db91fa7d8127fbd412667ea32/src/output/table.rs ./src/output/table.rs
|
||||
|
--- ../exa-57e4c08411f59e7db91fa7d8127fbd412667ea32/src/output/table.rs 2018-10-14 15:21:13.000000000 +0000
|
||||
|
+++ ./src/output/table.rs 2018-10-18 03:48:04.171402732 +0000
|
||||
|
@@ -246,6 +246,9 @@
|
||||
|
} |
||||
|
|
||||
|
pub fn load_all() -> Self { |
||||
|
+ #[cfg(target_os = "android")]
|
||||
|
+ let tz = None;
|
||||
|
+ #[cfg(not(target_os = "android"))]
|
||||
|
let tz = match determine_time_zone() { |
||||
|
Ok(t) => Some(t), |
||||
|
Err(ref e) => { |
Loading…
Reference in new issue