Browse Source
* file: update from 5.29 to 5.30 * ffmpeg: update from 3.2.2 to 3.2.4 * mpv: update from 0.23.0 to 0.24.0 also prevent opportunistic linking with x11 * grep: update from 2.28 to 3.0 * fish: update from 2.4.0 to 2.5.0 add tarball checksum remove patches no longer needed see https://github.com/fish-shell/fish-shell/pull/3585 * wget: update from 1.19 to 1.19.1android-5
Vishal Biswas
8 years ago
committed by
Fredrik Fornwall
9 changed files with 29 additions and 80 deletions
@ -1,8 +1,8 @@ |
|||||
TERMUX_PKG_HOMEPAGE=https://darwinsys.com/file/ |
TERMUX_PKG_HOMEPAGE=https://darwinsys.com/file/ |
||||
TERMUX_PKG_DESCRIPTION="Command-line tool that tells you in words what kind of data a file contains" |
TERMUX_PKG_DESCRIPTION="Command-line tool that tells you in words what kind of data a file contains" |
||||
TERMUX_PKG_VERSION=5.29 |
TERMUX_PKG_VERSION=5.30 |
||||
TERMUX_PKG_SRCURL=ftp://ftp.astron.com/pub/file/file-${TERMUX_PKG_VERSION}.tar.gz |
TERMUX_PKG_SRCURL=ftp://ftp.astron.com/pub/file/file-${TERMUX_PKG_VERSION}.tar.gz |
||||
TERMUX_PKG_SHA256=ea661277cd39bf8f063d3a83ee875432cc3680494169f952787e002bdd3884c0 |
TERMUX_PKG_SHA256=694c2432e5240187524c9e7cf1ec6acc77b47a0e19554d34c14773e43dbbf214 |
||||
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="ac_cv_func_mmap_fixed_mapped=yes" |
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="ac_cv_func_mmap_fixed_mapped=yes" |
||||
TERMUX_PKG_EXTRA_MAKE_ARGS="FILE_COMPILE=$TERMUX_PKG_HOSTBUILD_DIR/src/file" |
TERMUX_PKG_EXTRA_MAKE_ARGS="FILE_COMPILE=$TERMUX_PKG_HOSTBUILD_DIR/src/file" |
||||
TERMUX_PKG_HOSTBUILD="yes" |
TERMUX_PKG_HOSTBUILD="yes" |
||||
|
@ -1,12 +0,0 @@ |
|||||
diff -u -r ../fish-2.4b1/configure.ac ./configure.ac
|
|
||||
--- ../fish-2.4b1/configure.ac 2016-10-18 10:17:06.000000000 -0400
|
|
||||
+++ ./configure.ac 2016-10-19 17:39:47.630582854 -0400
|
|
||||
@@ -251,8 +251,7 @@
|
|
||||
|
|
||||
# Check for os dependant libraries for all binaries. |
|
||||
AC_SEARCH_LIBS( connect, socket, , [AC_MSG_ERROR([Cannot find the socket library, needed to build this package.] )] ) |
|
||||
AC_SEARCH_LIBS( nanosleep, rt, , [AC_MSG_ERROR([Cannot find the rt library, needed to build this package.] )] ) |
|
||||
-AC_SEARCH_LIBS( shm_open, rt, , [AC_MSG_ERROR([Cannot find the rt library, needed to build this package.] )] )
|
|
||||
AC_SEARCH_LIBS( pthread_create, pthread, , [AC_MSG_ERROR([Cannot find the pthread library, needed to build this package.] )] ) |
|
||||
AC_SEARCH_LIBS( setupterm, [ncurses tinfo curses], , [AC_MSG_ERROR([Could not find a curses implementation, needed to build fish. If this is Linux, try running 'sudo apt-get install libncurses5-dev' or 'sudo yum install ncurses-devel'])] ) |
|
||||
AC_SEARCH_LIBS( [dladdr], [dl] ) |
|
@ -1,20 +1,19 @@ |
|||||
diff -u -r ../fish-2.4b1/share/functions/__fish_print_help.fish ./share/functions/__fish_print_help.fish
|
--- ./share/functions/__fish_print_help.fish 2017-02-03 07:16:58.000000000 +0530
|
||||
--- ../fish-2.4b1/share/functions/__fish_print_help.fish 2016-10-18 10:17:06.000000000 -0400
|
+++ ../__fish_print_help.fish 2017-02-12 11:36:23.477232262 +0530
|
||||
+++ ./share/functions/__fish_print_help.fish 2016-10-19 17:37:08.948931562 -0400
|
@@ -41,7 +41,7 @@
|
||||
@@ -40,7 +40,7 @@
|
end |
||||
set rLL -rLL=$cols[1]n |
set -lx GROFF_TMAC_PATH $__fish_datadir/groff |
||||
end |
|
||||
if test -e "$__fish_datadir/man/man1/$item.1" |
if test -e "$__fish_datadir/man/man1/$item.1" |
||||
- set help (nroff -man -c -t $rLL "$__fish_datadir/man/man1/$item.1" ^/dev/null)
|
- set help (nroff -c -man -mfish -t $rLL "$__fish_datadir/man/man1/$item.1" ^/dev/null)
|
||||
+ set help (mandoc "$__fish_datadir/man/man1/$item.1" ^/dev/null)
|
+ set help (mandoc "$__fish_datadir/man/man1/$item.1" ^/dev/null))
|
||||
else if test -e "$__fish_datadir/man/man1/$item.1.gz" |
else if test -e "$__fish_datadir/man/man1/$item.1.gz" |
||||
set help (gunzip -c "$__fish_datadir/man/man1/$item.1.gz" ^/dev/null | nroff -man -c -t $rLL ^/dev/null) |
set help (gunzip -c "$__fish_datadir/man/man1/$item.1.gz" ^/dev/null | nroff -c -man -mfish -t $rLL ^/dev/null) |
||||
end |
end |
||||
@@ -98,6 +98,6 @@
|
@@ -99,6 +99,6 @@
|
||||
# skip it |
# skip it |
||||
end |
end |
||||
end |
end |
||||
- end | ul # post-process with `ul`, to interpret the old-style grotty escapes
|
- end | ul # post-process with `ul`, to interpret the old-style grotty escapes
|
||||
+ end # post-process with `ul`, to interpret the old-style grotty escapes
|
+ end # post-process with `ul`, to interpret the old-style grotty escapes
|
||||
echo # print a trailing blank line |
echo # print a trailing blank line |
||||
end |
end |
||||
|
@ -1,6 +1,6 @@ |
|||||
TERMUX_PKG_HOMEPAGE=https://www.gnu.org/software/grep/ |
TERMUX_PKG_HOMEPAGE=https://www.gnu.org/software/grep/ |
||||
TERMUX_PKG_DESCRIPTION="Command which searches one or more input files for lines containing a match to a specified pattern" |
TERMUX_PKG_DESCRIPTION="Command which searches one or more input files for lines containing a match to a specified pattern" |
||||
TERMUX_PKG_DEPENDS="pcre" |
TERMUX_PKG_DEPENDS="pcre" |
||||
TERMUX_PKG_VERSION=2.28 |
TERMUX_PKG_VERSION=3.0 |
||||
TERMUX_PKG_SRCURL=https://mirrors.kernel.org/gnu/grep/grep-${TERMUX_PKG_VERSION}.tar.xz |
TERMUX_PKG_SRCURL=https://mirrors.kernel.org/gnu/grep/grep-${TERMUX_PKG_VERSION}.tar.xz |
||||
TERMUX_PKG_SHA256=3bad4c23eeb8dfa2fa84cdbe368398f75fdcd54bde411db83b9ef7fba5b60185 |
TERMUX_PKG_SHA256=e2c81db5056e3e8c5995f0bb5d0d0e1cad1f6f45c3b2fc77b6e81435aed48ab5 |
||||
|
@ -1,7 +1,7 @@ |
|||||
TERMUX_PKG_HOMEPAGE=https://www.gnu.org/software/wget/ |
TERMUX_PKG_HOMEPAGE=https://www.gnu.org/software/wget/ |
||||
TERMUX_PKG_DESCRIPTION="Commandline tool for retrieving files using HTTP, HTTPS and FTP" |
TERMUX_PKG_DESCRIPTION="Commandline tool for retrieving files using HTTP, HTTPS and FTP" |
||||
TERMUX_PKG_VERSION=1.19 |
TERMUX_PKG_VERSION=1.19.1 |
||||
TERMUX_PKG_SRCURL=https://mirrors.kernel.org/gnu/wget/wget-${TERMUX_PKG_VERSION}.tar.xz |
TERMUX_PKG_SRCURL=https://mirrors.kernel.org/gnu/wget/wget-${TERMUX_PKG_VERSION}.tar.xz |
||||
TERMUX_PKG_SHA256=0f1157bbf4daae19f3e1ddb70c6ccb2067feb834a6aa23c9d9daa7f048606384 |
TERMUX_PKG_SHA256=0c950b9671881222a4d385b013c9604e98a8025d1988529dfca0e93617744cd2 |
||||
TERMUX_PKG_DEPENDS="pcre, openssl, libuuid, libandroid-support" |
TERMUX_PKG_DEPENDS="pcre, openssl, libuuid, libandroid-support" |
||||
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="--with-ssl=openssl --disable-iri" |
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="--with-ssl=openssl --disable-iri" |
||||
|
Loading…
Reference in new issue