Browse Source

update packages (#766)

* file: update from 5.29 to 5.30

* ffmpeg: update from 3.2.2 to 3.2.4

* mpv: update from 0.23.0 to 0.24.0

also prevent opportunistic linking with x11

* grep: update from 2.28 to 3.0

* fish: update from 2.4.0 to 2.5.0

add tarball checksum
remove patches no longer needed
see https://github.com/fish-shell/fish-shell/pull/3585

* wget: update from 1.19 to 1.19.1
android-5
Vishal Biswas 8 years ago
committed by Fredrik Fornwall
parent
commit
cfa043f9b4
  1. 4
      packages/ffmpeg/build.sh
  2. 4
      packages/file/build.sh
  3. 4
      packages/fish/build.sh
  4. 12
      packages/fish/configure.ac.patch
  5. 31
      packages/fish/share-functions-__fish_print_help.fish.patch
  6. 38
      packages/fish/src-env_universal_common.cpp.patch
  7. 4
      packages/grep/build.sh
  8. 8
      packages/mpv/build.sh
  9. 4
      packages/wget/build.sh

4
packages/ffmpeg/build.sh

@ -1,9 +1,9 @@
TERMUX_PKG_HOMEPAGE=https://ffmpeg.org TERMUX_PKG_HOMEPAGE=https://ffmpeg.org
TERMUX_PKG_DESCRIPTION="Tools and libraries to manipulate a wide range of multimedia formats and protocols" TERMUX_PKG_DESCRIPTION="Tools and libraries to manipulate a wide range of multimedia formats and protocols"
# NOTE: mpv has to be rebuilt and version bumped after updating ffmpeg. # NOTE: mpv has to be rebuilt and version bumped after updating ffmpeg.
TERMUX_PKG_VERSION=3.2.2 TERMUX_PKG_VERSION=3.2.4
TERMUX_PKG_SRCURL=https://www.ffmpeg.org/releases/ffmpeg-${TERMUX_PKG_VERSION}.tar.xz TERMUX_PKG_SRCURL=https://www.ffmpeg.org/releases/ffmpeg-${TERMUX_PKG_VERSION}.tar.xz
TERMUX_PKG_SHA256=3f01bd1fe1a17a277f8c84869e5d9192b4b978cb660872aa2b54c3cc8a2fedfc TERMUX_PKG_SHA256=6e38ff14f080c98b58cf5967573501b8cb586e3a173b591f3807d8f0660daf7a
TERMUX_PKG_FOLDERNAME=ffmpeg-$TERMUX_PKG_VERSION TERMUX_PKG_FOLDERNAME=ffmpeg-$TERMUX_PKG_VERSION
# libbz2 is used by matroska decoder: # libbz2 is used by matroska decoder:
# libvpx is the VP8 & VP9 video encoder for WebM, see # libvpx is the VP8 & VP9 video encoder for WebM, see

4
packages/file/build.sh

@ -1,8 +1,8 @@
TERMUX_PKG_HOMEPAGE=https://darwinsys.com/file/ TERMUX_PKG_HOMEPAGE=https://darwinsys.com/file/
TERMUX_PKG_DESCRIPTION="Command-line tool that tells you in words what kind of data a file contains" TERMUX_PKG_DESCRIPTION="Command-line tool that tells you in words what kind of data a file contains"
TERMUX_PKG_VERSION=5.29 TERMUX_PKG_VERSION=5.30
TERMUX_PKG_SRCURL=ftp://ftp.astron.com/pub/file/file-${TERMUX_PKG_VERSION}.tar.gz TERMUX_PKG_SRCURL=ftp://ftp.astron.com/pub/file/file-${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SHA256=ea661277cd39bf8f063d3a83ee875432cc3680494169f952787e002bdd3884c0 TERMUX_PKG_SHA256=694c2432e5240187524c9e7cf1ec6acc77b47a0e19554d34c14773e43dbbf214
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="ac_cv_func_mmap_fixed_mapped=yes" TERMUX_PKG_EXTRA_CONFIGURE_ARGS="ac_cv_func_mmap_fixed_mapped=yes"
TERMUX_PKG_EXTRA_MAKE_ARGS="FILE_COMPILE=$TERMUX_PKG_HOSTBUILD_DIR/src/file" TERMUX_PKG_EXTRA_MAKE_ARGS="FILE_COMPILE=$TERMUX_PKG_HOSTBUILD_DIR/src/file"
TERMUX_PKG_HOSTBUILD="yes" TERMUX_PKG_HOSTBUILD="yes"

4
packages/fish/build.sh

@ -1,8 +1,8 @@
TERMUX_PKG_HOMEPAGE=http://fishshell.com/ TERMUX_PKG_HOMEPAGE=http://fishshell.com/
TERMUX_PKG_DESCRIPTION="Shell geared towards interactive use" TERMUX_PKG_DESCRIPTION="Shell geared towards interactive use"
TERMUX_PKG_VERSION=2.4.0 TERMUX_PKG_VERSION=2.5.0
TERMUX_PKG_REVISION=2
TERMUX_PKG_SRCURL=https://github.com/fish-shell/fish-shell/releases/download/$TERMUX_PKG_VERSION/fish-${TERMUX_PKG_VERSION}.tar.gz TERMUX_PKG_SRCURL=https://github.com/fish-shell/fish-shell/releases/download/$TERMUX_PKG_VERSION/fish-${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SHA256=f8c0edadca2de379ccf305aeace660a9255fa2180c72e85e97705a24c256b2a5
# fish calls 'tput' from ncurses-utils, at least when cancelling (Ctrl+C) a command line. # fish calls 'tput' from ncurses-utils, at least when cancelling (Ctrl+C) a command line.
# man is needed since fish calls apropos during command completion. # man is needed since fish calls apropos during command completion.
TERMUX_PKG_DEPENDS="ncurses, libandroid-support, ncurses-utils, man" TERMUX_PKG_DEPENDS="ncurses, libandroid-support, ncurses-utils, man"

12
packages/fish/configure.ac.patch

@ -1,12 +0,0 @@
diff -u -r ../fish-2.4b1/configure.ac ./configure.ac
--- ../fish-2.4b1/configure.ac 2016-10-18 10:17:06.000000000 -0400
+++ ./configure.ac 2016-10-19 17:39:47.630582854 -0400
@@ -251,8 +251,7 @@
# Check for os dependant libraries for all binaries.
AC_SEARCH_LIBS( connect, socket, , [AC_MSG_ERROR([Cannot find the socket library, needed to build this package.] )] )
AC_SEARCH_LIBS( nanosleep, rt, , [AC_MSG_ERROR([Cannot find the rt library, needed to build this package.] )] )
-AC_SEARCH_LIBS( shm_open, rt, , [AC_MSG_ERROR([Cannot find the rt library, needed to build this package.] )] )
AC_SEARCH_LIBS( pthread_create, pthread, , [AC_MSG_ERROR([Cannot find the pthread library, needed to build this package.] )] )
AC_SEARCH_LIBS( setupterm, [ncurses tinfo curses], , [AC_MSG_ERROR([Could not find a curses implementation, needed to build fish. If this is Linux, try running 'sudo apt-get install libncurses5-dev' or 'sudo yum install ncurses-devel'])] )
AC_SEARCH_LIBS( [dladdr], [dl] )

31
packages/fish/share-functions-__fish_print_help.fish.patch

@ -1,20 +1,19 @@
diff -u -r ../fish-2.4b1/share/functions/__fish_print_help.fish ./share/functions/__fish_print_help.fish --- ./share/functions/__fish_print_help.fish 2017-02-03 07:16:58.000000000 +0530
--- ../fish-2.4b1/share/functions/__fish_print_help.fish 2016-10-18 10:17:06.000000000 -0400 +++ ../__fish_print_help.fish 2017-02-12 11:36:23.477232262 +0530
+++ ./share/functions/__fish_print_help.fish 2016-10-19 17:37:08.948931562 -0400 @@ -41,7 +41,7 @@
@@ -40,7 +40,7 @@ end
set rLL -rLL=$cols[1]n set -lx GROFF_TMAC_PATH $__fish_datadir/groff
end
if test -e "$__fish_datadir/man/man1/$item.1" if test -e "$__fish_datadir/man/man1/$item.1"
- set help (nroff -man -c -t $rLL "$__fish_datadir/man/man1/$item.1" ^/dev/null) - set help (nroff -c -man -mfish -t $rLL "$__fish_datadir/man/man1/$item.1" ^/dev/null)
+ set help (mandoc "$__fish_datadir/man/man1/$item.1" ^/dev/null) + set help (mandoc "$__fish_datadir/man/man1/$item.1" ^/dev/null))
else if test -e "$__fish_datadir/man/man1/$item.1.gz" else if test -e "$__fish_datadir/man/man1/$item.1.gz"
set help (gunzip -c "$__fish_datadir/man/man1/$item.1.gz" ^/dev/null | nroff -man -c -t $rLL ^/dev/null) set help (gunzip -c "$__fish_datadir/man/man1/$item.1.gz" ^/dev/null | nroff -c -man -mfish -t $rLL ^/dev/null)
end end
@@ -98,6 +98,6 @@ @@ -99,6 +99,6 @@
# skip it # skip it
end end
end end
- end | ul # post-process with `ul`, to interpret the old-style grotty escapes - end | ul # post-process with `ul`, to interpret the old-style grotty escapes
+ end # post-process with `ul`, to interpret the old-style grotty escapes + end # post-process with `ul`, to interpret the old-style grotty escapes
echo # print a trailing blank line echo # print a trailing blank line
end end

38
packages/fish/src-env_universal_common.cpp.patch

@ -10,41 +10,3 @@ diff -u -r ../fish-2.4b1/src/env_universal_common.cpp ./src/env_universal_common
tmpdir.append(uname); tmpdir.append(uname);
if (check_runtime_path(tmpdir.c_str()) != 0) { if (check_runtime_path(tmpdir.c_str()) != 0) {
debug(0, debug(0,
@@ -987,6 +987,7 @@
return result;
}
+#ifndef __ANDROID__
class universal_notifier_shmem_poller_t : public universal_notifier_t {
// This is what our shared memory looks like. Everything here is stored in network byte order
// (big-endian).
@@ -1127,6 +1128,7 @@
return usec_per_sec / 3; // 3 times a second
}
};
+#endif
/// A notifyd-based notifier. Very straightforward.
class universal_notifier_notifyd_t : public universal_notifier_t {
@@ -1410,7 +1412,9 @@
const char *name;
universal_notifier_t::notifier_strategy_t strat;
} options[] = {{"default", universal_notifier_t::strategy_default},
+#ifndef __ANDROID__
{"shmem", universal_notifier_t::strategy_shmem_polling},
+#endif
{"pipe", universal_notifier_t::strategy_named_pipe},
{"notifyd", universal_notifier_t::strategy_notifyd}};
const size_t opt_count = sizeof options / sizeof *options;
@@ -1463,9 +1467,11 @@
strat = resolve_default_strategy();
}
switch (strat) {
+#ifndef __ANDROID__
case strategy_shmem_polling: {
return new universal_notifier_shmem_poller_t();
}
+#endif
case strategy_notifyd: {
return new universal_notifier_notifyd_t();
}

4
packages/grep/build.sh

@ -1,6 +1,6 @@
TERMUX_PKG_HOMEPAGE=https://www.gnu.org/software/grep/ TERMUX_PKG_HOMEPAGE=https://www.gnu.org/software/grep/
TERMUX_PKG_DESCRIPTION="Command which searches one or more input files for lines containing a match to a specified pattern" TERMUX_PKG_DESCRIPTION="Command which searches one or more input files for lines containing a match to a specified pattern"
TERMUX_PKG_DEPENDS="pcre" TERMUX_PKG_DEPENDS="pcre"
TERMUX_PKG_VERSION=2.28 TERMUX_PKG_VERSION=3.0
TERMUX_PKG_SRCURL=https://mirrors.kernel.org/gnu/grep/grep-${TERMUX_PKG_VERSION}.tar.xz TERMUX_PKG_SRCURL=https://mirrors.kernel.org/gnu/grep/grep-${TERMUX_PKG_VERSION}.tar.xz
TERMUX_PKG_SHA256=3bad4c23eeb8dfa2fa84cdbe368398f75fdcd54bde411db83b9ef7fba5b60185 TERMUX_PKG_SHA256=e2c81db5056e3e8c5995f0bb5d0d0e1cad1f6f45c3b2fc77b6e81435aed48ab5

8
packages/mpv/build.sh

@ -1,9 +1,8 @@
TERMUX_PKG_HOMEPAGE=https://mpv.io/ TERMUX_PKG_HOMEPAGE=https://mpv.io/
TERMUX_PKG_DESCRIPTION="Command-line media player" TERMUX_PKG_DESCRIPTION="Command-line media player"
TERMUX_PKG_VERSION=0.23.0 TERMUX_PKG_VERSION=0.24.0
TERMUX_PKG_REVISION=1
TERMUX_PKG_SRCURL=https://github.com/mpv-player/mpv/archive/v${TERMUX_PKG_VERSION}.tar.gz TERMUX_PKG_SRCURL=https://github.com/mpv-player/mpv/archive/v${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SHA256=8aeefe5970587dfc454d2b89726b603f156bd7a9ae427654eef0d60c68d94998 TERMUX_PKG_SHA256=a41854fa0ac35b9c309ad692aaee67c8d4495c3546f11cb4cdd0a124195d3f15
TERMUX_PKG_FOLDERNAME=mpv-${TERMUX_PKG_VERSION} TERMUX_PKG_FOLDERNAME=mpv-${TERMUX_PKG_VERSION}
TERMUX_PKG_DEPENDS="ffmpeg, openal-soft" TERMUX_PKG_DEPENDS="ffmpeg, openal-soft"
TERMUX_PKG_RM_AFTER_INSTALL="share/icons share/applications" TERMUX_PKG_RM_AFTER_INSTALL="share/icons share/applications"
@ -21,7 +20,8 @@ termux_step_make_install () {
--disable-libass \ --disable-libass \
--disable-lua \ --disable-lua \
--enable-openal \ --enable-openal \
--disable-caca --disable-caca \
--disable-x11
./waf install ./waf install

4
packages/wget/build.sh

@ -1,7 +1,7 @@
TERMUX_PKG_HOMEPAGE=https://www.gnu.org/software/wget/ TERMUX_PKG_HOMEPAGE=https://www.gnu.org/software/wget/
TERMUX_PKG_DESCRIPTION="Commandline tool for retrieving files using HTTP, HTTPS and FTP" TERMUX_PKG_DESCRIPTION="Commandline tool for retrieving files using HTTP, HTTPS and FTP"
TERMUX_PKG_VERSION=1.19 TERMUX_PKG_VERSION=1.19.1
TERMUX_PKG_SRCURL=https://mirrors.kernel.org/gnu/wget/wget-${TERMUX_PKG_VERSION}.tar.xz TERMUX_PKG_SRCURL=https://mirrors.kernel.org/gnu/wget/wget-${TERMUX_PKG_VERSION}.tar.xz
TERMUX_PKG_SHA256=0f1157bbf4daae19f3e1ddb70c6ccb2067feb834a6aa23c9d9daa7f048606384 TERMUX_PKG_SHA256=0c950b9671881222a4d385b013c9604e98a8025d1988529dfca0e93617744cd2
TERMUX_PKG_DEPENDS="pcre, openssl, libuuid, libandroid-support" TERMUX_PKG_DEPENDS="pcre, openssl, libuuid, libandroid-support"
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="--with-ssl=openssl --disable-iri" TERMUX_PKG_EXTRA_CONFIGURE_ARGS="--with-ssl=openssl --disable-iri"

Loading…
Cancel
Save