Browse Source
Packages should not modify the global build environment as it causes side effects which could affect other packages. In this case a man page is already available and we can skip the doc/ folder.android-5
Fredrik Fornwall
7 years ago
3 changed files with 18 additions and 13 deletions
@ -0,0 +1,12 @@ |
|||||
|
diff -u -r ../indent-2.2.11/Makefile.in ./Makefile.in
|
||||
|
--- ../indent-2.2.11/Makefile.in 2010-01-31 16:25:35.000000000 +0000
|
||||
|
+++ ./Makefile.in 2018-06-07 22:50:57.895536279 +0000
|
||||
|
@@ -237,7 +237,7 @@
|
||||
|
top_builddir = @top_builddir@ |
||||
|
top_srcdir = @top_srcdir@ |
||||
|
AUTOMAKE_OPTIONS = no-texinfo.tex |
||||
|
-SUBDIRS = intl src doc po man
|
||||
|
+SUBDIRS = intl src po man
|
||||
|
BUILT_SOURCES = |
||||
|
EXTRA_DIST = README \ |
||||
|
config/config.rpath config/mkinstalldirs \ |
@ -1,15 +1,7 @@ |
|||||
TERMUX_PKG_HOMEPAGE=https://packages.debian.org/sid/indent |
TERMUX_PKG_HOMEPAGE=https://packages.debian.org/sid/indent |
||||
TERMUX_PKG_DESCRIPTION="C language source code formatting program" |
TERMUX_PKG_DESCRIPTION="C language source code formatting program" |
||||
TERMUX_PKG_VERSION=2.2.11 |
TERMUX_PKG_VERSION=2.2.11 |
||||
TERMUX_PKG_SRCURL=http://http.debian.net/debian/pool/main/i/indent/indent_$TERMUX_PKG_VERSION.orig.tar.gz |
|
||||
TERMUX_PKG_SHA256=aaff60ce4d255efb985f0eb78cca4d1ad766c6e051666073050656b6753a0893 |
TERMUX_PKG_SHA256=aaff60ce4d255efb985f0eb78cca4d1ad766c6e051666073050656b6753a0893 |
||||
|
TERMUX_PKG_SRCURL=http://http.debian.net/debian/pool/main/i/indent/indent_$TERMUX_PKG_VERSION.orig.tar.gz |
||||
TERMUX_PKG_DEPENDS="libandroid-support" |
TERMUX_PKG_DEPENDS="libandroid-support" |
||||
TERMUX_PKG_BUILD_IN_SRC=yes |
TERMUX_PKG_RM_AFTER_INSTALL="bin/texinfo2man" |
||||
TERMUX_PKG_HOSTBUILD=true |
|
||||
termux_step_post_extract_package() { |
|
||||
# this should detect if we are running inside termux docker image |
|
||||
if [ $HOME = "/home/builder" ] && [ "grep docker /proc/1/cgroup > /dev/null" ]; then |
|
||||
sudo apt update |
|
||||
sudo apt install texi2html |
|
||||
fi |
|
||||
} |
|
||||
|
@ -1,11 +1,12 @@ |
|||||
--- ../cache/indent-2.2.11/man/Makefile.in 2010-01-31 16:25:21.000000000 +0000
|
diff -u -r ../indent-2.2.11/man/Makefile.in ./man/Makefile.in
|
||||
+++ ./man/Makefile.in 2018-02-24 05:13:23.767243504 +0000
|
--- ../indent-2.2.11/man/Makefile.in 2010-01-31 16:25:21.000000000 +0000
|
||||
|
+++ ./man/Makefile.in 2018-06-07 22:52:13.810674067 +0000
|
||||
@@ -575,7 +575,7 @@
|
@@ -575,7 +575,7 @@
|
||||
|
|
||||
|
|
||||
@PACKAGE@.1: ${srcdir}/@PACKAGE@.1.in ${srcdir}/../doc/@PACKAGE@.texinfo texinfo2man Makefile.am |
@PACKAGE@.1: ${srcdir}/@PACKAGE@.1.in ${srcdir}/../doc/@PACKAGE@.texinfo texinfo2man Makefile.am |
||||
- ./texinfo2man ${srcdir}/@PACKAGE@.1.in ${srcdir}/../doc/@PACKAGE@.texinfo > $@
|
- ./texinfo2man ${srcdir}/@PACKAGE@.1.in ${srcdir}/../doc/@PACKAGE@.texinfo > $@
|
||||
+ ../../host-build/man/texinfo2man ${srcdir}/@PACKAGE@.1.in ${srcdir}/../doc/@PACKAGE@.texinfo > $@
|
+ @echo Skipping
|
||||
|
|
||||
# Tell versions [3.59,3.63) of GNU make to not export all variables. |
# Tell versions [3.59,3.63) of GNU make to not export all variables. |
||||
# Otherwise a system limit (for SysV at least) may be exceeded. |
# Otherwise a system limit (for SysV at least) may be exceeded. |
Loading…
Reference in new issue