Browse Source

timewarrior: Patch for system include path

So that <glob.h> is found in Termux custom include dir.
android-5
Fredrik Fornwall 8 years ago
parent
commit
eb81fe3346
  1. 2
      disabled-packages/timewarrior/build.sh
  2. 9
      disabled-packages/timewarrior/src-CMakeLists.txt.patch

2
disabled-packages/timewarrior/build.sh

@ -9,7 +9,9 @@ TERMUX_PKG_VERSION=1.0.0
TERMUX_PKG_SRCURL=http://taskwarrior.org/download/timew-${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_DEPENDS="libandroid-glob"
termux_step_pre_configure() {
LDFLAGS+=" -landroid-glob"
}
termux_step_configure () {
cd $TERMUX_PKG_BUILDDIR

9
disabled-packages/timewarrior/src-CMakeLists.txt.patch

@ -0,0 +1,9 @@
diff -u -r ../timew-1.0.0/src/CMakeLists.txt ./src/CMakeLists.txt
--- ../timew-1.0.0/src/CMakeLists.txt 2016-08-17 17:23:15.000000000 -0400
+++ ./src/CMakeLists.txt 2016-09-05 17:53:00.643967527 -0400
@@ -1,4 +1,5 @@
cmake_minimum_required (VERSION 2.8)
+include_directories(SYSTEM "@TERMUX_PREFIX@/include")
include_directories (${CMAKE_SOURCE_DIR}
${CMAKE_SOURCE_DIR}/src
${CMAKE_SOURCE_DIR}/src/commands
Loading…
Cancel
Save