Browse Source

fish: Build from master

android-5
Fredrik Fornwall 9 years ago
parent
commit
f54c910984
  1. 12
      packages/fish/Makefile.in.patch
  2. 12
      packages/fish/build.sh
  3. 4
      packages/fish/complete.cpp.patch
  4. 2
      packages/fish/env_universal_common.cpp.patch
  5. 2
      packages/fish/env_universal_common.h.patch
  6. 13
      packages/fish/exec.cpp.patch
  7. 2
      packages/fish/fish_tests.cpp.patch
  8. 2
      packages/fish/reader.cpp.patch
  9. 2
      packages/fish/wutil.cpp.patch
  10. 12
      packages/fish/xdgmimemagic.cpp.patch

12
packages/fish/Makefile.in.patch

@ -0,0 +1,12 @@
diff -u -r ../fish-shell-master/Makefile.in ./Makefile.in
--- ../fish-shell-master/Makefile.in 2015-09-30 09:14:09.000000000 -0400
+++ ./Makefile.in 2015-09-30 18:30:13.271683017 -0400
@@ -59,7 +59,7 @@
PCRE2_LIBDIR = $(PCRE2_DIR)/.libs
PCRE2_LIB = $(PCRE2_LIBDIR)/libpcre2-$(PCRE2_WIDTH).a
PCRE2_H = $(PCRE2_DIR)/src/pcre2.h
-PCRE2_CONFIG = --disable-pcre2-8 --enable-pcre2-$(PCRE2_WIDTH) --disable-shared
+PCRE2_CONFIG = --disable-pcre2-8 --enable-pcre2-$(PCRE2_WIDTH) --disable-shared $(PCRE2_CONFIG_EXTRAS)
#
# Various flags

12
packages/fish/build.sh

@ -1,13 +1,19 @@
TERMUX_PKG_HOMEPAGE=http://fishshell.com/
TERMUX_PKG_DESCRIPTION="Shell geared towards interactive use"
TERMUX_PKG_VERSION=2.2.0
TERMUX_PKG_SRCURL=http://fishshell.com/files/${TERMUX_PKG_VERSION}/fish-${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_DEPENDS="ncurses, libgnustl"
TERMUX_PKG_VERSION=2.2.0.`date "+%Y%m%d%H%M"`
# TERMUX_PKG_SRCURL=http://fishshell.com/files/${TERMUX_PKG_VERSION}/fish-${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SRCURL=https://github.com/fish-shell/fish-shell/archive/master.zip
TERMUX_PKG_DEPENDS="ncurses, libgnustl, libandroid-support"
TERMUX_PKG_BUILD_IN_SRC=yes
TERMUX_PKG_FOLDERNAME=fish-shell-master
termux_step_pre_configure () {
cd $TERMUX_PKG_SRCDIR
autoconf
CXXFLAGS+=" $CPPFLAGS"
LDFLAGS+=" -lgnustl_shared"
export PCRE2_CONFIG_EXTRAS="--host=$TERMUX_HOST_PLATFORM"
}

4
packages/fish/complete.cpp.patch

@ -1,6 +1,6 @@
diff -u -r ../fish-2.1.1/complete.cpp ./complete.cpp
diff -u -r ../fish-2.1.1/complete.cpp ./src/complete.cpp
--- ../fish-2.1.1/complete.cpp 2014-09-24 05:51:07.000000000 -0400
+++ ./complete.cpp 2015-02-05 17:43:46.010415990 -0500
+++ ./src/complete.cpp 2015-02-05 17:43:46.010415990 -0500
@@ -1731,6 +1731,9 @@
*/
bool completer_t::try_complete_user(const wcstring &str)

2
packages/fish/env_universal_common.cpp.patch

@ -1,6 +1,6 @@
diff -u -r ../fish-2.2.0/env_universal_common.cpp ./env_universal_common.cpp
--- ../fish-2.2.0/env_universal_common.cpp 2015-07-03 15:46:59.000000000 -0400
+++ ./env_universal_common.cpp 2015-07-13 02:16:14.591286575 -0400
+++ ./src/env_universal_common.cpp 2015-07-13 02:16:14.591286575 -0400
@@ -1089,6 +1089,7 @@
return result;
}

2
packages/fish/env_universal_common.h.patch

@ -1,6 +1,6 @@
diff -u -r ../fish-2.2.0/env_universal_common.h ./env_universal_common.h
--- ../fish-2.2.0/env_universal_common.h 2015-07-03 15:46:59.000000000 -0400
+++ ./env_universal_common.h 2015-07-25 17:52:47.555388223 -0400
+++ ./src/env_universal_common.h 2015-07-25 17:52:47.555388223 -0400
@@ -123,8 +123,10 @@
// Default meta-strategy to use the 'best' notifier for the system
strategy_default,

13
packages/fish/exec.cpp.patch

@ -0,0 +1,13 @@
diff -u -r ../fish-shell-master/src/exec.cpp ./src/exec.cpp
--- ../fish-shell-master/src/exec.cpp 2015-09-30 09:14:09.000000000 -0400
+++ ./src/exec.cpp 2015-09-30 18:13:06.563764498 -0400
@@ -18,7 +18,9 @@
#include <assert.h>
#include <vector>
#include <algorithm>
+#ifdef FISH_USE_POSIX_SPAWN
#include <spawn.h>
+#endif
#include <wctype.h>
#include <map>
#include <string>

2
packages/fish/fish_tests.cpp.patch

@ -1,6 +1,6 @@
diff -u -r ../fish-2.2.0/fish_tests.cpp ./fish_tests.cpp
--- ../fish-2.2.0/fish_tests.cpp 2015-07-03 15:46:59.000000000 -0400
+++ ./fish_tests.cpp 2015-07-13 02:17:00.378612789 -0400
+++ ./src/fish_tests.cpp 2015-07-13 02:17:00.378612789 -0400
@@ -2572,9 +2572,11 @@
assert(0 && "strategy_default should be passed");
break;

2
packages/fish/reader.cpp.patch

@ -1,6 +1,6 @@
diff -u -r ../fish-2.1.1/reader.cpp ./reader.cpp
--- ../fish-2.1.1/reader.cpp 2014-09-24 05:51:07.000000000 -0400
+++ ./reader.cpp 2015-02-05 17:37:16.298415721 -0500
+++ ./src/reader.cpp 2015-02-05 17:37:16.298415721 -0500
@@ -1961,12 +1961,7 @@
{
/* Try reading from the tty; if we get EIO we are orphaned. This is sort of bad because it may block. */

2
packages/fish/wutil.cpp.patch

@ -1,6 +1,6 @@
diff -u -r ../fish-2.2.0/wutil.cpp ./wutil.cpp
--- ../fish-2.2.0/wutil.cpp 2015-07-03 15:46:59.000000000 -0400
+++ ./wutil.cpp 2015-07-16 08:55:37.131915467 -0400
+++ ./src/wutil.cpp 2015-07-16 08:55:37.131915467 -0400
@@ -531,7 +531,7 @@
result.size = buf->st_size;
result.change_seconds = buf->st_ctime;

12
packages/fish/xdgmimemagic.cpp.patch

@ -1,12 +0,0 @@
diff -u -r ../fish-2.1.1/xdgmimemagic.cpp ./xdgmimemagic.cpp
--- ../fish-2.1.1/xdgmimemagic.cpp 2014-09-24 05:51:07.000000000 -0400
+++ ./xdgmimemagic.cpp 2015-02-05 17:41:08.686415882 -0500
@@ -47,8 +47,6 @@
#define TRUE (!FALSE)
#endif
-extern int errno;
-
typedef struct XdgMimeMagicMatch XdgMimeMagicMatch;
typedef struct XdgMimeMagicMatchlet XdgMimeMagicMatchlet;
Loading…
Cancel
Save