Fredrik Fornwall
9 years ago
10 changed files with 41 additions and 22 deletions
@ -0,0 +1,12 @@ |
|||
diff -u -r ../fish-shell-master/Makefile.in ./Makefile.in
|
|||
--- ../fish-shell-master/Makefile.in 2015-09-30 09:14:09.000000000 -0400
|
|||
+++ ./Makefile.in 2015-09-30 18:30:13.271683017 -0400
|
|||
@@ -59,7 +59,7 @@
|
|||
PCRE2_LIBDIR = $(PCRE2_DIR)/.libs |
|||
PCRE2_LIB = $(PCRE2_LIBDIR)/libpcre2-$(PCRE2_WIDTH).a |
|||
PCRE2_H = $(PCRE2_DIR)/src/pcre2.h |
|||
-PCRE2_CONFIG = --disable-pcre2-8 --enable-pcre2-$(PCRE2_WIDTH) --disable-shared
|
|||
+PCRE2_CONFIG = --disable-pcre2-8 --enable-pcre2-$(PCRE2_WIDTH) --disable-shared $(PCRE2_CONFIG_EXTRAS)
|
|||
|
|||
# |
|||
# Various flags |
@ -1,13 +1,19 @@ |
|||
TERMUX_PKG_HOMEPAGE=http://fishshell.com/ |
|||
TERMUX_PKG_DESCRIPTION="Shell geared towards interactive use" |
|||
TERMUX_PKG_VERSION=2.2.0 |
|||
TERMUX_PKG_SRCURL=http://fishshell.com/files/${TERMUX_PKG_VERSION}/fish-${TERMUX_PKG_VERSION}.tar.gz |
|||
TERMUX_PKG_DEPENDS="ncurses, libgnustl" |
|||
TERMUX_PKG_VERSION=2.2.0.`date "+%Y%m%d%H%M"` |
|||
# TERMUX_PKG_SRCURL=http://fishshell.com/files/${TERMUX_PKG_VERSION}/fish-${TERMUX_PKG_VERSION}.tar.gz |
|||
TERMUX_PKG_SRCURL=https://github.com/fish-shell/fish-shell/archive/master.zip |
|||
TERMUX_PKG_DEPENDS="ncurses, libgnustl, libandroid-support" |
|||
TERMUX_PKG_BUILD_IN_SRC=yes |
|||
TERMUX_PKG_FOLDERNAME=fish-shell-master |
|||
|
|||
termux_step_pre_configure () { |
|||
cd $TERMUX_PKG_SRCDIR |
|||
autoconf |
|||
|
|||
CXXFLAGS+=" $CPPFLAGS" |
|||
|
|||
LDFLAGS+=" -lgnustl_shared" |
|||
|
|||
export PCRE2_CONFIG_EXTRAS="--host=$TERMUX_HOST_PLATFORM" |
|||
} |
|||
|
@ -0,0 +1,13 @@ |
|||
diff -u -r ../fish-shell-master/src/exec.cpp ./src/exec.cpp
|
|||
--- ../fish-shell-master/src/exec.cpp 2015-09-30 09:14:09.000000000 -0400
|
|||
+++ ./src/exec.cpp 2015-09-30 18:13:06.563764498 -0400
|
|||
@@ -18,7 +18,9 @@
|
|||
#include <assert.h> |
|||
#include <vector> |
|||
#include <algorithm> |
|||
+#ifdef FISH_USE_POSIX_SPAWN
|
|||
#include <spawn.h> |
|||
+#endif
|
|||
#include <wctype.h> |
|||
#include <map> |
|||
#include <string> |
@ -1,12 +0,0 @@ |
|||
diff -u -r ../fish-2.1.1/xdgmimemagic.cpp ./xdgmimemagic.cpp
|
|||
--- ../fish-2.1.1/xdgmimemagic.cpp 2014-09-24 05:51:07.000000000 -0400
|
|||
+++ ./xdgmimemagic.cpp 2015-02-05 17:41:08.686415882 -0500
|
|||
@@ -47,8 +47,6 @@
|
|||
#define TRUE (!FALSE) |
|||
#endif |
|||
|
|||
-extern int errno;
|
|||
-
|
|||
typedef struct XdgMimeMagicMatch XdgMimeMagicMatch; |
|||
typedef struct XdgMimeMagicMatchlet XdgMimeMagicMatchlet; |
|||
|
Loading…
Reference in new issue