Fredrik Fornwall
6 years ago
10 changed files with 14 additions and 130 deletions
@ -1,21 +0,0 @@ |
|||||
--- /home/vagrant/ruby-2.5.0/configure.ac 2017-12-15 09:43:40.000000000 +0000
|
|
||||
+++ src/configure.ac 2018-02-14 19:07:11.272257521 +0000
|
|
||||
@@ -742,7 +742,7 @@
|
|
||||
rb_cv_warnflags="$warnflags" |
|
||||
AS_IF([test "$GCC:${warnflags+set}:no" = yes::no], [ |
|
||||
AS_IF([test $gcc_major -ge 4], [ |
|
||||
- extra_warning=-Werror=extra-tokens
|
|
||||
+ extra_warning=
|
|
||||
], [ |
|
||||
extra_warning= |
|
||||
]) |
|
||||
@@ -765,9 +765,7 @@
|
|
||||
-Werror=pointer-arith \ |
|
||||
-Werror=write-strings \ |
|
||||
-Werror=declaration-after-statement \ |
|
||||
- -Werror=shorten-64-to-32 \
|
|
||||
-Werror=implicit-function-declaration \ |
|
||||
- -Werror=division-by-zero \
|
|
||||
-Werror=deprecated-declarations \ |
|
||||
-Werror=misleading-indentation \ |
|
||||
-Wno-packed-bitfield-compat \ |
|
@ -1,21 +0,0 @@ |
|||||
--- /home/vagrant/ruby-2.5.0/configure 2017-12-25 07:00:28.000000000 +0000
|
|
||||
+++ src/configure 2018-02-14 19:06:28.742701948 +0000
|
|
||||
@@ -7434,7 +7434,7 @@
|
|
||||
|
|
||||
if test $gcc_major -ge 4; then : |
|
||||
|
|
||||
- extra_warning=-Werror=extra-tokens
|
|
||||
+ extra_warning=
|
|
||||
|
|
||||
else |
|
||||
|
|
||||
@@ -7464,9 +7464,7 @@
|
|
||||
-Werror=pointer-arith \ |
|
||||
-Werror=write-strings \ |
|
||||
-Werror=declaration-after-statement \ |
|
||||
- -Werror=shorten-64-to-32 \
|
|
||||
-Werror=implicit-function-declaration \ |
|
||||
- -Werror=division-by-zero \
|
|
||||
-Werror=deprecated-declarations \ |
|
||||
-Werror=misleading-indentation \ |
|
||||
-Wno-packed-bitfield-compat \ |
|
@ -1,13 +0,0 @@ |
|||||
--- /home/vagrant/ruby-2.5.0/lib/fileutils.rb 2017-12-22 08:00:10.000000000 +0000
|
|
||||
+++ ./lib/fileutils.rb 2018-02-17 23:19:55.344655246 +0000
|
|
||||
@@ -744,8 +744,8 @@
|
|
||||
# |
|
||||
def compare_stream(a, b) |
|
||||
bsize = fu_stream_blksize(a, b) |
|
||||
- sa = String.new(capacity: bsize)
|
|
||||
- sb = String.new(capacity: bsize)
|
|
||||
+ sa = String.new
|
|
||||
+ sb = String.new
|
|
||||
begin |
|
||||
a.read(bsize, sa) |
|
||||
b.read(bsize, sb) |
|
@ -1,14 +0,0 @@ |
|||||
diff -u -r ../ruby-2.4.0/lib/rubygems/defaults.rb ./lib/rubygems/defaults.rb
|
|
||||
--- ../ruby-2.4.0/lib/rubygems/defaults.rb 2016-06-24 06:13:11.000000000 +0200
|
|
||||
+++ ./lib/rubygems/defaults.rb 2017-01-31 22:53:59.125074751 +0100
|
|
||||
@@ -191,6 +191,9 @@
|
|
||||
# end |
|
||||
|
|
||||
def self.platform_defaults |
|
||||
- {}
|
|
||||
+ {
|
|
||||
+ 'install' => '--no-rdoc --no-ri --env-shebang',
|
|
||||
+ 'update' => '--no-rdoc --no-ri --env-shebang'
|
|
||||
+ }
|
|
||||
end |
|
||||
end |
|
@ -1,12 +0,0 @@ |
|||||
diff -u -r ../ruby-2.4.0/lib/rubygems/installer.rb ./lib/rubygems/installer.rb
|
|
||||
--- ../ruby-2.4.0/lib/rubygems/installer.rb 2016-09-28 03:16:43.000000000 +0200
|
|
||||
+++ ./lib/rubygems/installer.rb 2017-01-31 22:49:11.992624578 +0100
|
|
||||
@@ -31,7 +31,7 @@
|
|
||||
# Paths where env(1) might live. Some systems are broken and have it in |
|
||||
# /bin |
|
||||
|
|
||||
- ENV_PATHS = %w[/usr/bin/env /bin/env]
|
|
||||
+ ENV_PATHS = %w[@TERMUX_PREFIX@/bin/env /usr/bin/env]
|
|
||||
|
|
||||
## |
|
||||
# Deprecated in favor of Gem::Ext::BuildError |
|
@ -1,11 +0,0 @@ |
|||||
--- /home/vagrant/ruby-2.5.0/template/configure-ext.mk.tmpl 2017-04-23 16:19:22.000000000 +0000
|
|
||||
+++ ./template/configure-ext.mk.tmpl 2018-02-17 23:31:02.304445580 +0000
|
|
||||
@@ -24,7 +24,7 @@
|
|
||||
MINIRUBY = <%=miniruby%> |
|
||||
SCRIPT_ARGS = <%=script_args%> |
|
||||
EXTMK_ARGS = $(SCRIPT_ARGS) --gnumake=$(gnumake) --extflags="$(EXTLDFLAGS)" \ |
|
||||
- --make-flags='MINIRUBY=$(MINIRUBY)'
|
|
||||
+ --make-flags="MINIRUBY='$(MINIRUBY)'"
|
|
||||
|
|
||||
all: exts gems |
|
||||
exts: |
|
Loading…
Reference in new issue