Oliver Schmidhauser
8 years ago
committed by
Fredrik Fornwall
2 changed files with 16 additions and 15 deletions
@ -1,14 +1,21 @@ |
|||||
diff --git a/Makefile b/Makefile
|
diff --git a/Makefile b/Makefile
|
||||
index 5028ee4..6294b23 100644
|
index 5028ee4..f3ce14f 100644
|
||||
--- a/Makefile
|
--- a/Makefile
|
||||
+++ b/Makefile
|
+++ b/Makefile
|
||||
@@ -11,7 +11,8 @@ MANPATH = ${DESTDIR}${PREFIX}/share/man/man1
|
@@ -9,16 +9,8 @@ PREFIX ?= /usr/local
|
||||
|
INSTALLPATH = ${DESTDIR}${PREFIX}/bin |
||||
|
MANPATH = ${DESTDIR}${PREFIX}/share/man/man1 |
||||
|
|
||||
ifeq ($(shell sh -c 'which ncurses5-config>/dev/null 2>/dev/null && echo y'), y) |
-ifeq ($(shell sh -c 'which ncurses5-config>/dev/null 2>/dev/null && echo y'), y)
|
||||
CFLAGS += -Wall -g $$(ncurses5-config --cflags) |
- CFLAGS += -Wall -g $$(ncurses5-config --cflags)
|
||||
- LDFLAGS += $$(ncurses5-config --libs)
|
- LDFLAGS += $$(ncurses5-config --libs)
|
||||
+ # Overwrite instead of appending LDFLAGS, because `ncurses-config --libs` also returns -ltinfo, which it can't find
|
-else ifeq ($(shell sh -c 'which ncursesw5-config>/dev/null 2>/dev/null && echo y'), y)
|
||||
+ LDFLAGS ?= $$(ncurses5-config --libs)
|
- CFLAGS += -Wall -g $$(ncursesw5-config --cflags)
|
||||
else ifeq ($(shell sh -c 'which ncursesw5-config>/dev/null 2>/dev/null && echo y'), y) |
- LDFLAGS += $$(ncursesw5-config --libs)
|
||||
CFLAGS += -Wall -g $$(ncursesw5-config --cflags) |
-else
|
||||
LDFLAGS += $$(ncursesw5-config --libs) |
CFLAGS += -Wall -g $$(pkg-config --cflags ncurses) |
||||
|
LDFLAGS += $$(pkg-config --libs ncurses) |
||||
|
-endif
|
||||
|
|
||||
|
tty-clock : ${SRC} |
||||
|
|
||||
|
Loading…
Reference in new issue