Fredrik Fornwall
9 years ago
24 changed files with 101 additions and 242 deletions
@ -0,0 +1,18 @@ |
|||||
|
The r11 of NDK removed dprintf. |
||||
|
|
||||
|
diff -u -r ../busybox-1.24.1/include/platform.h ./include/platform.h
|
||||
|
--- ../busybox-1.24.1/include/platform.h 2015-07-13 04:18:47.000000000 +0200
|
||||
|
+++ ./include/platform.h 2016-03-10 11:47:06.000000000 +0100
|
||||
|
@@ -480,11 +480,7 @@
|
||||
|
#endif |
||||
|
|
||||
|
#if defined(ANDROID) || defined(__ANDROID__) |
||||
|
-# if __ANDROID_API__ < 8
|
||||
|
-# undef HAVE_DPRINTF
|
||||
|
-# else
|
||||
|
-# define dprintf fdprintf
|
||||
|
-# endif
|
||||
|
+# undef HAVE_DPRINTF
|
||||
|
# if __ANDROID_API__ < 21 |
||||
|
# undef HAVE_TTYNAME_R |
||||
|
# undef HAVE_GETLINE |
@ -1,14 +0,0 @@ |
|||||
fdprintf() does not exist in 64-bit bionic. |
|
||||
|
|
||||
diff -u -r ../busybox-1.24.1/include/platform.h ./include/platform.h |
|
||||
--- ../busybox-1.24.1/include/platform.h 2015-07-12 22:18:47.000000000 -0400 |
|
||||
+++ ./include/platform.h 2015-11-26 16:14:37.061610995 -0500 |
|
||||
@@ -480,7 +480,7 @@ |
|
||||
#endif |
|
||||
|
|
||||
#if defined(ANDROID) || defined(__ANDROID__) |
|
||||
-# if __ANDROID_API__ < 8 |
|
||||
+# if __ANDROID_API__ < 8 || defined(__LP64__) |
|
||||
# undef HAVE_DPRINTF |
|
||||
# else |
|
||||
# define dprintf fdprintf |
|
@ -0,0 +1,11 @@ |
|||||
|
diff -u -r ../llvm-3.8.0.src/Makefile ./Makefile
|
||||
|
--- ../llvm-3.8.0.src/Makefile 2014-03-25 17:45:41.000000000 -0400
|
||||
|
+++ ./Makefile 2016-03-10 16:28:00.142389801 -0500
|
||||
|
@@ -69,7 +69,6 @@
|
||||
|
ifeq ($(MAKECMDGOALS),install-clang) |
||||
|
DIRS := tools/clang/tools/driver tools/clang/lib/Headers \ |
||||
|
tools/clang/tools/libclang \ |
||||
|
- tools/clang/tools/c-index-test \
|
||||
|
tools/clang/include/clang-c \ |
||||
|
tools/clang/runtime tools/clang/docs \ |
||||
|
tools/lto |
@ -1,11 +1,11 @@ |
|||||
diff -u -r ../orig-src/tools/clang/tools/CMakeLists.txt ./tools/clang/tools/CMakeLists.txt
|
diff -u -r ../orig-src/tools/clang/tools/CMakeLists.txt ./tools/clang/tools/CMakeLists.txt
|
||||
--- ../orig-src/tools/clang/tools/CMakeLists.txt 2014-03-06 11:07:50.000000000 +0100
|
--- ../orig-src/tools/clang/tools/CMakeLists.txt 2016-01-12 21:03:50.000000000 -0500
|
||||
+++ ./tools/clang/tools/CMakeLists.txt 2014-03-06 11:06:10.000000000 +0100
|
+++ ./tools/clang/tools/CMakeLists.txt 2016-03-10 16:32:04.320055824 -0500
|
||||
@@ -3,7 +3,6 @@
|
@@ -6,7 +6,6 @@
|
||||
add_subdirectory(clang-format) |
add_clang_subdirectory(clang-format-vs) |
||||
add_subdirectory(clang-format-vs) |
add_clang_subdirectory(clang-fuzzer) |
||||
|
|
||||
-add_subdirectory(c-index-test)
|
-add_clang_subdirectory(c-index-test)
|
||||
add_subdirectory(libclang) |
add_clang_subdirectory(libclang) |
||||
|
|
||||
if(CLANG_ENABLE_ARCMT) |
if(CLANG_ENABLE_ARCMT) |
||||
|
@ -0,0 +1,21 @@ |
|||||
|
diff -u -r ../gdb-7.11/gdb/gdbserver/configure ./gdb/gdbserver/configure
|
||||
|
--- ../gdb-7.11/gdb/gdbserver/configure 2016-02-09 22:19:39.000000000 -0500
|
||||
|
+++ ./gdb/gdbserver/configure 2016-03-10 10:17:40.111988028 -0500
|
||||
|
@@ -6735,17 +6735,6 @@
|
||||
|
|
||||
|
|
||||
|
case "${target}" in |
||||
|
- *-android*)
|
||||
|
- # Starting with NDK version 9, <elf.h> actually includes definitions
|
||||
|
- # of Elf32_auxv_t and Elf64_auxv_t. But sadly, <elf.h> includes
|
||||
|
- # <sys/exec_elf.h> which defines some of the ELF types incorrectly,
|
||||
|
- # leading to conflicts with the defintions from <linux/elf.h>.
|
||||
|
- # This makes it impossible for us to include both <elf.h> and
|
||||
|
- # <linux/elf.h>, which means that, in practice, we do not have
|
||||
|
- # access to Elf32_auxv_t and Elf64_auxv_t on this platform.
|
||||
|
- # Therefore, do not try to auto-detect availability, as it would
|
||||
|
- # get it wrong on this platform.
|
||||
|
- ;;
|
||||
|
*) |
||||
|
ac_fn_c_check_type "$LINENO" "Elf32_auxv_t" "ac_cv_type_Elf32_auxv_t" "#include <elf.h> |
||||
|
|
@ -1,12 +0,0 @@ |
|||||
diff -u -r ../gdb-7.8.1/gdb/gdbserver/gdb_proc_service.h ./gdb/gdbserver/gdb_proc_service.h
|
|
||||
--- ../gdb-7.8.1/gdb/gdbserver/gdb_proc_service.h 2014-06-11 12:34:41.000000000 -0400
|
|
||||
+++ ./gdb/gdbserver/gdb_proc_service.h 2014-12-22 07:53:22.855702229 -0500
|
|
||||
@@ -38,6 +38,8 @@
|
|
||||
# endif |
|
||||
#endif |
|
||||
|
|
||||
+#include "../gregset.h" /* for elf_gregset_t */
|
|
||||
+
|
|
||||
typedef enum |
|
||||
{ |
|
||||
PS_OK, /* Success. */ |
|
@ -1,15 +0,0 @@ |
|||||
diff -u -r ../gdb-7.9/gdb/i386-linux-nat.c ./gdb/i386-linux-nat.c
|
|
||||
--- ../gdb-7.9/gdb/i386-linux-nat.c 2015-02-19 06:58:07.000000000 -0500
|
|
||||
+++ ./gdb/i386-linux-nat.c 2015-03-17 18:14:06.728805213 -0400
|
|
||||
@@ -35,6 +35,11 @@
|
|
||||
|
|
||||
#include "x86-linux-nat.h" |
|
||||
|
|
||||
+#ifdef __ANDROID__
|
|
||||
+#include <sys/ucontext.h>
|
|
||||
+typedef fpregset_t elf_fpxregset_t;
|
|
||||
+#endif
|
|
||||
+
|
|
||||
/* The register sets used in GNU/Linux ELF core-dumps are identical to |
|
||||
the register sets in `struct user' that is used for a.out |
|
||||
core-dumps, and is also used by `ptrace'. The corresponding types |
|
@ -1,11 +0,0 @@ |
|||||
diff -u -r ../gdb-7.8.1/gdb/gdbserver/linux-arm-low.c ./gdb/gdbserver/linux-arm-low.c
|
|
||||
--- ../gdb-7.8.1/gdb/gdbserver/linux-arm-low.c 2014-10-29 15:45:50.000000000 -0400
|
|
||||
+++ ./gdb/gdbserver/linux-arm-low.c 2014-12-22 07:57:06.035702383 -0500
|
|
||||
@@ -26,6 +26,7 @@
|
|
||||
#endif |
|
||||
#include <sys/ptrace.h> |
|
||||
#include <signal.h> |
|
||||
+#include <linux/auxvec.h> /* for AT_HWCAP define */
|
|
||||
|
|
||||
/* Defined in auto-generated files. */ |
|
||||
void init_registers_arm (void); |
|
@ -1,23 +0,0 @@ |
|||||
diff -u -r ../gdb-7.9/gdb/gdbserver/linux-x86-low.c ./gdb/gdbserver/linux-x86-low.c
|
|
||||
--- ../gdb-7.9/gdb/gdbserver/linux-x86-low.c 2015-02-19 06:58:07.000000000 -0500
|
|
||||
+++ ./gdb/gdbserver/linux-x86-low.c 2015-03-17 18:29:50.412805866 -0400
|
|
||||
@@ -38,6 +38,11 @@
|
|
||||
#include "tracepoint.h" |
|
||||
#include "ax.h" |
|
||||
|
|
||||
+#ifdef __ANDROID__
|
|
||||
+#include <sys/ucontext.h>
|
|
||||
+typedef fpregset_t elf_fpxregset_t;
|
|
||||
+#endif
|
|
||||
+
|
|
||||
#ifdef __x86_64__ |
|
||||
/* Defined in auto-generated file amd64-linux.c. */ |
|
||||
void init_registers_amd64_linux (void); |
|
||||
@@ -113,7 +118,6 @@
|
|
||||
#endif |
|
||||
|
|
||||
#include <sys/reg.h> |
|
||||
-#include <sys/procfs.h>
|
|
||||
#include <sys/ptrace.h> |
|
||||
#include <sys/uio.h> |
|
||||
|
|
@ -1,37 +0,0 @@ |
|||||
diff -u -r ../gdb-7.8.1/gdb/gdbserver/linux-low.c ./gdb/gdbserver/linux-low.c
|
|
||||
--- ../gdb-7.8.1/gdb/gdbserver/linux-low.c 2014-10-29 15:45:50.000000000 -0400
|
|
||||
+++ ./gdb/gdbserver/linux-low.c 2014-12-22 07:51:39.355702157 -0500
|
|
||||
@@ -47,6 +47,7 @@
|
|
||||
#include "filestuff.h" |
|
||||
#include "tracepoint.h" |
|
||||
#include "hostio.h" |
|
||||
+#include <linux/auxvec.h> /* For AT_PHDR and AT_PHNUM defines */
|
|
||||
#ifndef ELFMAG0 |
|
||||
/* Don't include <linux/elf.h> here. If it got included by gdb_proc_service.h |
|
||||
then ELFMAG0 will have been defined. If it didn't get included by |
|
||||
@@ -108,7 +109,6 @@
|
|
||||
# include "linux-btrace.h" |
|
||||
#endif |
|
||||
|
|
||||
-#ifndef HAVE_ELF32_AUXV_T
|
|
||||
/* Copied from glibc's elf.h. */ |
|
||||
typedef struct |
|
||||
{ |
|
||||
@@ -121,9 +121,7 @@
|
|
||||
on 64-bit platforms and vice versa. */ |
|
||||
} a_un; |
|
||||
} Elf32_auxv_t; |
|
||||
-#endif
|
|
||||
|
|
||||
-#ifndef HAVE_ELF64_AUXV_T
|
|
||||
/* Copied from glibc's elf.h. */ |
|
||||
typedef struct |
|
||||
{ |
|
||||
@@ -136,7 +134,6 @@
|
|
||||
on 64-bit platforms and vice versa. */ |
|
||||
} a_un; |
|
||||
} Elf64_auxv_t; |
|
||||
-#endif
|
|
||||
|
|
||||
/* A list of all unknown processes which receive stop signals. Some |
|
||||
other process will presumably claim each of these as forked |
|
@ -1,24 +0,0 @@ |
|||||
diff -u -r ../gdb-7.8.1/gdb/config/nm-linux.h ./gdb/config/nm-linux.h
|
|
||||
--- ../gdb-7.8.1/gdb/config/nm-linux.h 2014-06-11 12:34:41.000000000 -0400
|
|
||||
+++ ./gdb/config/nm-linux.h 2014-12-22 07:45:14.127701891 -0500
|
|
||||
@@ -20,5 +20,20 @@
|
|
||||
/* Use elf_gregset_t and elf_fpregset_t, rather than |
|
||||
gregset_t and fpregset_t. */ |
|
||||
|
|
||||
+#ifndef NM_CONFIG_LINUX_H
|
|
||||
+#define NM_CONFIG_LINUX_H
|
|
||||
+
|
|
||||
+#include <sys/ucontext.h>
|
|
||||
+
|
|
||||
+#ifdef __arm__
|
|
||||
+/* Structure to describe FPU registers. */
|
|
||||
+typedef struct fpregset { } fpregset_t;
|
|
||||
+#endif
|
|
||||
+
|
|
||||
+typedef gregset_t elf_gregset_t;
|
|
||||
+typedef fpregset_t elf_fpregset_t;
|
|
||||
+
|
|
||||
#define GDB_GREGSET_T elf_gregset_t |
|
||||
#define GDB_FPREGSET_T elf_fpregset_t |
|
||||
+
|
|
||||
+#endif
|
|
@ -1,11 +0,0 @@ |
|||||
diff -u -r ../gdb-7.6.2/gdb/proc-service.c ./gdb/proc-service.c
|
|
||||
--- ../gdb-7.6.2/gdb/proc-service.c 2013-12-08 05:33:13.000000000 +0100
|
|
||||
+++ ./gdb/proc-service.c 2014-01-07 16:43:01.866311352 +0100
|
|
||||
@@ -27,7 +27,6 @@
|
|
||||
|
|
||||
#include "gdb_proc_service.h" |
|
||||
|
|
||||
-#include <sys/procfs.h>
|
|
||||
|
|
||||
/* Prototypes for supply_gregset etc. */ |
|
||||
#include "gregset.h" |
|
@ -1,23 +0,0 @@ |
|||||
diff -u -r ../gdb-7.9/gdb/x86-linux-nat.c ./gdb/x86-linux-nat.c
|
|
||||
--- ../gdb-7.9/gdb/x86-linux-nat.c 2015-02-20 12:11:44.000000000 -0500
|
|
||||
+++ ./gdb/x86-linux-nat.c 2015-03-17 18:20:50.044805492 -0400
|
|
||||
@@ -23,7 +23,6 @@
|
|
||||
#include "gdb_proc_service.h" |
|
||||
#include <sys/ptrace.h> |
|
||||
#include <sys/user.h> |
|
||||
-#include <sys/procfs.h>
|
|
||||
#include <sys/uio.h> |
|
||||
|
|
||||
#include "x86-nat.h" |
|
||||
@@ -39,6 +38,11 @@
|
|
||||
#include "x86-xstate.h" |
|
||||
#include "nat/linux-btrace.h" |
|
||||
|
|
||||
+#ifdef __ANDROID__
|
|
||||
+#include <sys/ucontext.h>
|
|
||||
+typedef fpregset_t elf_fpxregset_t;
|
|
||||
+#endif
|
|
||||
+
|
|
||||
/* Per-thread arch-specific data we want to keep. */ |
|
||||
|
|
||||
struct arch_lwp_info |
|
@ -0,0 +1,14 @@ |
|||||
|
The tkill(2) function was removed from libc in NDK r11. |
||||
|
|
||||
|
diff -u -r ../bdwgc-c861ec3d1825b5bb450d20bf9091562fa8a81a4d/pthread_stop_world.c ./pthread_stop_world.c
|
||||
|
--- ../bdwgc-c861ec3d1825b5bb450d20bf9091562fa8a81a4d/pthread_stop_world.c 2016-01-13 03:34:56.000000000 -0500
|
||||
|
+++ ./pthread_stop_world.c 2016-03-10 07:09:03.607785056 -0500
|
||||
|
@@ -450,7 +450,7 @@
|
||||
|
#endif |
||||
|
|
||||
|
#ifdef USE_TKILL_ON_ANDROID |
||||
|
- extern int tkill(pid_t tid, int sig); /* from sys/linux-unistd.h */
|
||||
|
+ static int tkill(pid_t tid, int sig) { return tgkill(-1, tid, sig); }
|
||||
|
|
||||
|
static int android_thread_kill(pid_t tid, int sig) |
||||
|
{ |
Loading…
Reference in new issue